NEI not working under MineOS


#1

Im using MineOS as secondary OS on my old laptop(Intel Atom@2GB). Everything is working fine. Except, when i tried to install NEI(CodeChickenCore included) it’s simply doesn’t work on a clientside. Deleting NEI on serverside made clientside partially working, but this is not what i want. Tried everything i found on Google. Doesn’t work. But, when i started same server on a ordinary Win10 PC everything worked as it should.

Also, im fairly newbie to MineOS and this forum. And sorry for my Engrish.


#2

hi Steamturbine,

i am confused by many things you have said. they just do not make sense to me.

however i will point out items you state that i do understand.

no problem but you need to clarify: are you trying to run a modded mc server with 2gb of ram? on a dual boot system? and you have started and played on a vanilla (non-modded server) with MineOs? what version?

as far as i know, you can not start and run a MineOs server with win10 running on a pc.

NEI requires codechickencore AND FORGE. you do not indicate what versions of forge, nei and ccc you are using and if they are compatible.

OR are you talking about two different systems that you have attempted to run a modded forge server, one worked and one did not? if so, begin with assuming 2gb of ram is under equipped to run a modded forge server. minimum of 3gb to start and 4gb would be better. please ensure all java arguments are appropriately set

good luck!

tNt


#3

Hi tNt, thank you for response.

Yes. Its a dualboot MineOS/Win10 system. Ive started playing on a MineOS server on 1.12.1. But now i am on 1.7.10 Forge-based server we’re talking about.

Nope(maybe with VM), but in my case MineOS running directly on a hardware.

Correct, two different PC’s with same server-files, one worked, one not. The one that worked is Win10@i7-860@8GB, no other OS’s installed on it.

Memory footprint of this server is slightly bigger than 1gb. While ive allocated 1536mb for it. I don’t think that the problem is here.

Which ones? Ive never used Java arguments(except for memory allocation). And it’s always worked fine.

Forge 10.13.4.1614-1.7.10
CodeChickenCore 1.7.10-1.0.7.47-universal
NotEnoughItems 1.7.10-1.0.5.120-universal


#4

hi Steamturbine,

just trying to help while you wait for the next better advices.

the memory allocation is what i meant, so:

you allocated 1.5gb of a two gb system to minecraft itself, correct?

leaving how much for MineOS (the operating system)? and the min. requirement would be?

i still have to advise 2gb is slim but could be ok for a vanilla 1.7.10 server. did you get that up and running first, by the way? (plain 1.7.10?)

you could try 1.125gb or 1.25gb to see if that is helpfull. if it began to work then you narrow the issue down somewhat.

i would need more time to confirm compatibility and as luck would have it we are shifting house so i have disconnected and packed up the server, sorry. but if they did work on your other (8gb) system you have, then i see no issue there.

keep trying!

tNt


#6

Godd time-a-day, tNt.

Yea, i know, this is not how it is supposed to be. But, there is still ~700mb free and no gamebreaking glithes/crashes were noticed.

Tried 1024, 1152, 1280, all the same. Gotta stick with 1536. Since i don’t need more than 1 server running at a time.


#7

hi Steamturbine,

any luck for you?

regards,

tNt


#8

Hi tNt

Nope, nothing worked.


#9

Hi tNt

I don’t know how, but i got it to work properly.
Thank you for replying.