Need some help getting mineos and dynmap to function together minecraft version 1.12.2 modded dedicated server with forge 2640


#1

need some help getting mineos and dynmap to function together minecraft version 1.12.2 modded dedicated server with forge 2640.

hi, as the title says i have been trying ever since 1.7.10 to get dynmap and mineos to function together, but have NEVER found a solution, the problem is that no matter the configuration (portforwarding, config files, etc, the works) i can never actually open the dynmap webpage through any method.

i tried going to 192.168.1.11:8123
i tried changing the port (range) to 8124 (through 8129) and using the appropriate port numbers
i tried using the external IP with a : and the correct port number after it
i tried using the http:// prefix before all of these other listed tries

[edit] i forgot to say but the result of all/any things i’ve tried are a 404 error message that the connection timed out when going to the link.

i’ve also double checked firewall settings in windows firewall, added explicitly, inbound and outbound rules for BOTH TCP and UDP explicitly allowing the ports, DESPITE windows firewall being configured to be fully off and allow these connections without a rule anyway
[/edit]

the server is an old desktop PC running in a headless configuration with mineos turnkey installed and configured (as far as i know) properly, everything else i try and do works perfectly, except for this mod.

one thing i have to consider is some kind of webserver (?) or webserver configuration needed by dynmap may possibly be missing (don’t ask me, i couldn’t tell you what, or how to configure it due to lack of any useful instructions for use with mineos or vice versa) and required for dynmap to function.

lastly, i will just say that i don’t care how much effort this requires, i am 100% willing to wipe the server’s hard drives entirely and install a wholly different server software, different distribution of mineos, or whatever else may be required.

anyway, thank you for reading and please for crying out loud someone provide something, i don’t care what or how much effort is required that resolves this!


#2

i have verified that i can reach the mineos web user interface using the external IP and port number NOT listed here properly.


#3

also, i am attempting to use dynmap forge as i am unable to find what appears to be any way to use forge and bukkit together.

i am 100% open to using a plugin version or what have you so long as i can still use forge mods.


#4

additionally, i have now verified that dynmap mod jar file is being run on the server and commands do appear to function, so it isn’t a problem of the mod not being loaded.


#5

i’ve been doing some more research and now i’m wondering if i should install mineos CRUX instead of mineos TURNKEY as CRUX appears to include a (hiawatha) webserver by default and TURNKEY says it does not.

i am unsure however if this is actually needed for dynmap to function properly or not.


#6

so apparently the problem was as simple as the iptables needed to be edited to allow the dynmap port to be visible and forwarded, this issue has been keeping me from using dynmap as long as i’ve been using mineos, i’m so happy to have this fixed for once.

didn’t even realize an OS like mineos meant for hosting dedicated game servers would have a built in firewall.


#7

It’s good to see that you figured this out yourself.

All linux / unix OS systems have portmap for firewall. MineOS in it self is not an OS, but run as an WebUI on top of a turnkey Linux installation. Turnkey is a slimmed down Debian clone. In stead of creating an enitre OS from the bottom up, MineOS offers a WebUI that relies on, and uses, the underlying OS’es file-, user- , and security systems. That gives @hexparrot time to focus on MineOS functionality in stead of basic OS functionality.

As for firewalls and security: You want ALL and ANY system that has an open line to the internet to have firewalling and security. There is too much crap and creeps out there that want to use any chance and system they can get their hands on for their own nefariuos purposes. You’ll only want to turn off MineOS’s portmap if you are dead certain that it is behind another firewall.