Modpack help


#1

Hello, can i install CrazyCraft. How do i import a modpack. I have mineos turnkey.


#2

From what I’ve googled, Crazycraft requires a Launcher (something that requires a graphical interface). If this is accurate, and Crazycraft must launch from a graphical interface, then no, this wouldn’t be possible.

Do you have any idea if it’s possible to install this from command line? If so, I can adapt instructions for it to work on MineOS.


#3

I had a server once from a Minecraf tHosting Company, and there was a option, on profiles, CrazyCraft so i think there is a way, and i see alot of youtubers playing crazycraft on a server.

I cant code anywhere, so i dont know.


#4

As far as I can see, the launcher is for clientside use.

CrazyCraft host their own servers, and have a cooperation with a host service to allow private crazycraft servers easily.

The modpacs used are available, but not as an simple install. You have to use one of the modded server types, then add all the mods crazycraft uses, while also figuring out what mods are singleplayer or clientside only, or other mods that do not work well on a server. Some hints found here: http://forums.technicpack.net/topic/128799-how-to-create-a-crazy-craft-server/

@tNt is our expert on modded servers and may be able to help.


#5

When I downloaded CrazyCraft 3.0 and tried running it from the command line, I got this:

mc@mineos servers/asdf$ java -jar crazycraft3.jar nogui
A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:564)
        at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:43)
        at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:12)
Caused by: java.lang.ClassCastException: java.base/jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to java.base/java.net.URLClassLoader
        at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)
        at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
        ... 6 more

Tried it without arguments, with -nogui and nogui; all returned a launcher error. Inside the CrazyCraft3.zip file also are “Linux and Mac Launch Helpers” whose contents were:

#!/bin/bash
cd ..
java -jar crazycraft3.jar -XMX1G
pause

So looks like I’m invoking it as expected, but just can’t seem to find anything suggesting a CLI-only launch just yet.