MineOS won't start

Whenever I try to start MineOS on a brand new installation, I get this error:
I reinstalled twice and redownloaded the iso, but it won’t work, how can I fix this?

Which ISO did you download?

The one named “Current ISO” at https://minecraft.codeemo.com/mineoswiki/index.php?title=Main_Page#MineOS_Availability

I suspect you have a java version mismatch. Try updating your Java version

I installed OpenJDK 8 without the dev tools and I get the same error, weird it wasn’t installed because the download page said MineOS came with it out of the box

Where are you getting this error? Or more specifically, how is this error being triggered?

On the Official ISO, the webui service starts automatically (and you wouldn’t see this output–it should be hidden and logged), so knowing what you’re doing immediately prior to this error can help us understand what the problem is at the core.

The web-ui never started, so I opened ssh to see what was up and I noticed a “mineos” program, and i got this when I tried to run it

Running the scripts from the ‘reset the webui’ might help out here:


If it doesn’t become evident what the problem from there is, we should take a look at the logfile: /var/log/mineos.log

It seems to be fixed now. Thanks!