MineOS WebUI won't load locale-en_US.json and is not usable


#1

Hi,

I installed MineOS using DietPi. I can access the backend but it seems to be broken because some JSON files can’t be loaded. The result is that I can’t install a server. Screenshot: https://i.imgur.com/j9TAv81.png

The error in Chrome is "Failed to load resource: “net::ERR_CONNECTION_REFUSED”

I tried Safari and Firefox. I also tried to run generate-sslcert.sh again. Any idea? Here is my log: https://pastebin.com/PU5mnn4C

Thanks in advance for your help!


#2

Your log shows this error:

uncaughtException: Cannot find module '/mnt/dietpi_userdata/mineos/minecraft/node_modules/userid/build/Debug/userid.node

It tells me that in the previous step, the userid npm module failed to build, which could have a cascading effect for a number of failures.

It also shows me you’re using Node v10.1.0. Is it possible you can try using a lower version? It was designed and maintained against 4.x, but there have been many reports of even v8.x working A-ok.

The steps would be:

  1. uninstall node v10
  2. install node 4.x / 8.x
  3. rebuild the modules in /usr/games/minecraft with npm install

The number of nodejs related issues are rising, and I’m feeling the mounting pressure to try to get all of the webui running on a more modern version. Here’s to hoping I can make that happen.