MineOS Stuck On Starting

I have a 3.5ghz E3 NAS with 128gb cached ssd, and 16gb RAM. The server is running FreeNAS with 9.3.5 mineos installed. I setup a FTB server downloaded from the profile, I run the FTBinstall.sh, and then I start the server. Then the server starts (if I go under dashboard it shows its running), but the log only shows “[15:08:04] [Server thread/INFO]: Starting minecraft server version 1.7.10”. I then can’t stop, restart, or kill the server. The only way I have been able to shut it down is to reboot my OS.

Any help would be great.


Did you run FTBinstall.sh as root or as a non-root user?

Can you verify the ownership of the files for that server are the non-root user?

I ran it as root. I should also add that when I try to run a “normal non-bukkit” version of minecraft the server starts up fine. I do not know how to check ownership of files on freenas.


Running scripts as root mean that new files created/modified by its actions will be owned by root. However, you should not be running any minecraft servers as root (you should be logging in as a non-root user), so the non-root user cannot actually work with the files that were downloaded.

You check ownership with the ls -la command (or many variants of ls), which will show user ownership and group ownership:

drwxr-xr-x 20 root root 680 Nov 2 20:20 mineos-node

As a result, things won’t work. You’ll need to correct it by first chown-ing the files to be owned by your other, non-root user.

chown -R /var/games/minecraft/servers/* will:will

Replace the path if it differs and the username/group, as needed.

And then from here on, make sure that when you’re dealing with servers, you don’t use root.