@ mineos start webui don't start

During an update of Webui I got many errors and most have been fixed just a couple glitches to go. I know things are not right in the webui but I can use it now. When I reboot server Webui does not load up.

As root I ran:
cd /usr/games/minecraft
git fetch

  • remote: Counting obts: 5, done.
  • remote: Compressing objects: 100% (1/1), done.
  • remote: Total 5 (delta 4), reused 5 (delta 4), pack-reused 0
  • Unpacking objects: 100% (5/5), done.
  • From https://github.com/hexparrot/mineos-node
  • _ [new branch] mianite -> origin/mianite_
    git merge origin/master
  • Already up-to-date

npm install

cd /usr/games/minecraft
git fetch
git reset --hard origin/master

  • HEAD is now at 08d2edc fixed issue: webui crash if missing jarfile
    rm -rf node_modules
    npm install

  • npm WARN deprecated graceful-fs@3.0.8

  • npm WARN deprecated static-favicon@2.0.3

  • npm WARN deprecated native of blueberry@1.2.0

  • npm WARN deprecated graceful-fs@2.0.3

  • Output from commands

Webui, Webmin, putty and SCP connect to the server now but at a command as root I need to run:

cd /usr/games/minecraft
node webui.js

The log below is of a hardware start then webui via command line. and repeat that action of second boot of hard and webui.


Since we now know that the WebUI starts when you fire it up manually, we know it works. It is just the autostart feature that do not fire.

Have you tried this (from HOW TO: install MINEOS-NODE on UBUNTU SERVER 14.04.2):


sudo cp /usr/games/minecraft/init/upstart_conf /etc/init/mineos.conf
sudo start mineos

This is for an Ubuntu Server 14.04.2 clean install, so your OS may have other commands for adding to the autostart-feature. Did you download one of the precompiled MineOS images and install from scratch? Or did you install a linux-version first, then added MineOS ?

1 Like

No I have not tried anything yet, I have learned that the wrong command can bring the servers down so I’m not chancing anything unless I know it will not stop my servers from running. I download the pre-compiled ISO. I did think of a fresh install of the newest MineOS turnkey node, the thing that is stopping me is I need to move my database to an offsite location so I can format and start over, I didn’t not think this over enough when I started to use mySQL. My website hosting offers free mySQL which would be the better choice then on my in-house server.

Oh. OK.

I run from a stock Ubuntu Server 14, and added MineOS on top, so I’m not to familiar with the Turnkey environment.

@hexparrot: (sorry to bring you in again) the commands used for autostarting MineOS on Ubuntu 14 (from the wiki I linked above), are they the same on Turnkey?

It is weird though. the Mineos turnkey comes ready set up, so autostart should work, but as you say @ironic_8b49, an bungled update may have done something to the autostart settings.

Let’s look at the other path: Backup and reinstall:
If a myql dump is the only thing holding you back this is the command line command (ssh command) to dump all your entire mySQL bases:

mysqldump --all-databases > all_databases.sql 

“all_databases.sql” may be renamed to whatever you want it to be, just make sure it ends in “.sql”. Another hot tip: Do not delete and format anything before you are sure your database dump is working by importing it to its new location first!

If you do not wish to export all databases into one file you may use this command:

mysqldump database_name > database_name.sql

Again: Swap “database_name” for what your database is named

To get all the minecraft servers out: use the archive functions and copy the archives. the archives can be directly imported into a fresh MineOS installation, recreating the servers as they where on the old server.

Thanks for the info on how to backup my SQL, I will back up Monday and get the databases to work on my godaddy hosting accounting.

OK I ran command in putty logged into mysql as the user and I got syntax error. then I said maybe I 'm running in wrong location, so logged out of mysql and ran ion command line got mc user access denied. So I went to the server (not in putty) where I was still logged in as root and the error messages I got from starting up webui is a two spamming error messages about econnrefused and this IP and port they are servers I don’t run cause I use for testing. I guess my question is I do I need to be at command line as root to backup database?

My bad.
No, you need to be authenticated in MySQL, so you need to provide username and password for the MySQL base:

All bases: 
mysqldump -uUSERNAME -pPASSWORD -hHOSTNAME --all-databases > all_databases.sql

One base at at time: 
mysqldump -uUSERNAME -pPASSWORD -hHOSTNAME database_name > database_name.sql

Please note there is no space between -u and user name and -p and password
-hHOSTNAME can be dropped, since it defaults to localhost, if you are backing up on the srever running MySQL.

OK I backed up SQL inside one of my servers folders so it would get backed up in the archive, my question is to restore database does all the servers have to be not connected to it?

No. MySQL (and databases) is a store of data. Your servers connect to that store to add and retreive data.

In fact: You have to create the databases first for the servers to be able to connect to it.

This discussion is now way outside the scope of this forum; support for the MineOS platform, and over into spesific minecraft servers, AND MySQL. As I do not run any servers that are connected to MySQL (by my choice, I prefered the simplicity of having the posibility of making one server archive containing all my server files for easier restore and reinstalls), I suggest you ask further help with this in the apropriate forums (As in MySQL help forums, and the help forums of the minecraft server you are running (Spigot, vanilla, and so on). This is a forum for help with MineOS, not minecraft srvers or MySQL.

OK, if I have any questions that fit in the scope of this forum I will ask.

As I said; You are now out of the scope of this forum, and over in MySQL help. I am really starting to get to the boundries of my knowledge now, and where I usually run into problems my self, having to experiment and google to find solutions.

I’ll give you some links to MySQL help threads discussing what you are trying to do:



I am sorry I cannot be of any more help now, but you are now doing things, and having problems, that there exists other forums to help you with.

I had question in the works when you posted it was going outside the scope, that’s why I edited it. Thanks for the the info I’m sure I will be able to figure it out

1 Like

No problem :smiley:
We just got in a loop where we edited or answered each other out of sync, and therefore ended up answering a previous unedited version of a post: D

Good luck! You’ll figure this out!

OK took some time but I started a fresh install of Jessie Turnkey, Webui is even slower then older Turnkey, what is the problem

I decided to release the slow, non-functioning webui to replace the older one.

funny, after a few hours is started to run at normal speed does it automatically update itself in background?

No, the webui never updates itself; it must be done manually using the instructions from the wiki.