MineOS Server Set Up Issues

I am having two Issues.

First: When I attempt to set up a server, using the stock server zip file for a Feed the Beast modpack called The Dark Trilogy, I get “Ignoring command {import_server};archive contains files with absolute path or …” I cannot for the life of me find were there is any absolute pathing or parent directory indicators anywhere in the zip file. I get the same error, when unzipping and using 7zip to tar.gz the file.

Second: I had an Agrarian Skies server running on the MineOS Machine (this is all on a VirtualBox Vm btw), it worked fine. When I tried to add the Dark Trilogy, that is when everything went to hell. Even the exact same Agrarian Skies zip, would no longer install. Agrarian Skies wasnt saying there was absolutes or parent directory indicators, it started saying that the touch command was “permission denied”. I did some checking, and the OS was creating new folders but giving root the ownership of them, and obviously, the third permission set in linux usually defaults to 4, so the mc user in webui couldnt write to a folder it has no permissions in.

None of this was an issue 2 weeks ago when I installed Agrarian Skies originally. I have wiped the VM 4 times and started over to ensure it isnt the installation being corrupted. Ive also wiped and re downloaded both 32 and 64 bit turnkey, re installed, and it fails the same way on both.

I don’t know what the issue is or where to go from here.

I’m sorry to hear you’re running into issues; importing is one of the least consistent features because it heavily suggests that any file zipped or tar-gzipped can simply be imported. For the most part, success can really only be assured when it is importing an archive that MineOS has also made.

That said, you can do a few things to help narrow down the culprit:

  1. create a brand new server with a stock profile, such as vanilla 1.8–not an import
  2. check: does the server work? does creating the profile work ok? do the directory permissions seem right?

If any of those questions are negative, something went wrong since the install. Probably best to reinstall and continue the rest of these instructions.

If the stock server works, next try:

  1. create a brand new server with a new profile for your FTB + Dark Trilogy. You are able to set up a profile that can download this, right? If so, also let me know what it is so I can attempt to reproduce it.
  2. check: does it create and run a new, blank world with FTB+Dark Trilogy?

If it works, then we know that the permissions and the profile are OK. It’s good to know that we got this far–if we get this far, we can deduce that all of the problem remaining is from the import, which is consistent with what you’re also seeing with “archive contains …”

To short circuit this, I’d also be happy to look at the original zip file you’re working with and test it personally.

BEFORE YOU DO THE ABOVE: The one thing I’m most concerned about is whether you’re trying to import a server pack vs create the server pack as a profile.

import is for server data, and includes the server.properties files, world/ directory, etc. A Stock server zip file for FTB should never return “{import_server}”, because import_server is very different than profiles.

To verify, let me know what you filled in for the fields in your profile–all of em. I’m thinking at this point it’s pretty much just a slight mix-up with you importing the server jar…which is not the expected behavior.

I did make a default server. It worked.
Everything seemed ok.

I was able to set up a profile to download the Dark Trilogy zip file. However when attempting to create the server directory, you only get the server.properties and one other file (sorry I am at school and cant recall which file it was, but it was one of the server files).

What I did, was i created the server on my desktop. Ran it. Verified that my adjustments to the config files worked fine (just disabling a few blocks in the config designated true/false entries, nothing else). Zipped and uploaded it to my MineOS VM.

Another thing that I did, was I copied the directly downloaded zip file to the imports directory, and attempted to make a server, I got the same error as when i used my own uploaded zip with a fully generated server. The Import Server error.

I also used a copy of my agrarian skies world to attempt set up, but it was prevented from setting up by the permissions issue. It didnt seem to have any import issues, but the permissions issue prevented set up. The strange part, is the Agrarian Skies was zipped from one MineOS VM, and pushed to another MineOS VM, via my Windows Desktop. When this gave me the permissions error, I was surprised, and so I wiped my Agrarian Skies server from its Originating MineOS VM and tried to re-install it, and got the permissions error there as well.

These same errors were replicated 4 or 5 times, across 3 or 4 different virtual machines. Each VM was separately created, not cloned.

Sadly, due to these errors, I have ditched mineOS in favor of a simple Ubuntu system. The AromaCore/AromaBackup mod provides me with hourly backups of the server, and while this is less than desirable in regards to total space used by backups, it took me 15 minutes to get the server up and running “the hard way” as opposed to the 2 or 3 days I spent trying to trouble shoot MineOS.

I no longer have MineOS installed in a VM. However, if you wish to fix any errors that might be in the MineOS itself, I am willing to re-install it and replicate my issues.

I’m sorry MineOS didn’t work out for you, and I wish you the best of luck with your current setup.

Ultimately, we weren’t given enough information to know how to reproduce your issue and to pinpoint what it was. For example, when you said you set up a profile, you didn’t tell us what you filled in, as requested. I understand for many users, the profiles system isn’t immediately intuitive–because most people package their server jars with the world files (as you have). However, there is nothing special about what MineOS does in this regard–it simply keeps two separate steps as two separate steps–named profiles and importing; this separation makes updating server jars going forward much easier.

Here, you may have been attempting the same issue as before, where you are expecting–simply through importing–for your world files and your server jars to be ready to be run, which we know now is not the case.

MineOS is a front-end, and not much more. What MineOS does, quite literally, is shield a user from having to know and properly type in commands that run a Java instance and a Minecraft jar.

The commands you’ve done in your Ubuntu setup will be very familiar to what MineOS does, because every command in MineOS pretty much translates to a CLI command you could type in.

If the files are in the right directory, and they are owned by a non-root user, any configuration will work. You ran into some Linux-generic issues with permissions (which I’m sure could be easily figured out with help) and some unfamiliar convention issues (which MineOS introduces, that I created); since you have it up and running as you want, I won’t bother you to step back and try it again.

All the same, thank you for your attempt at trying MineOS and good luck with your server!

Try the guide that I’ve developed and have on this topic.
Setting up MineOS and ModServer