MineOS running in VM VirtualBox port 8080 not free on

So I’m hitting a bit of a wall here in relation to networking on a virtual machine. I have port forwarded correctly using a NAT network and I have also used a bridged network, both have the same problem. When trying to start the server through the WebUI the UI indicates a successful start but the server won’t start, I have gone through and tried everything in the wiki including resetting and updating the WebUI to no avail. I’m sure this is a firewall/routing issue but I need a little something to direct my focus in the right direction.

Not sure what info I need to post so please let me know if there is anything else I should share!

Here is the mineos.log with a fresh service start. P.S. the service tries to initialize at start but fails. I have also successfully run this OS build on a dedicated disk, using VM to test without damaging the main server.

[29/Jul/2015:06:50:25] ENGINE Bus STARTING

[29/Jul/2015:06:50:25] ENGINE Forking once.
[29/Jul/2015:06:50:25] ENGINE Forking twice.
[29/Jul/2015:06:50:25] ENGINE Daemonized to PID: 3859
[29/Jul/2015:06:50:25] ENGINE Started monitor thread ‘Autoreloader’.
[29/Jul/2015:06:50:25] ENGINE Started monitor thread ‘_TimeoutMonitor’.
[29/Jul/2015:06:50:25] ENGINE PID 3859 written to ‘/var/run/mineos.pid’.
[29/Jul/2015:06:50:25] ENGINE Started monitor thread ‘Monitor’.
[29/Jul/2015:06:50:30] ENGINE Error in ‘start’ listener <bound method Server.start of <cherrypy._cpserver.Server object at 0x1f8ad10>>
Traceback (most recent call last):
File “/usr/local/lib/python2.7/dist-packages/cherrypy/process/wspbus.py”, line 197, in publish
output.append(listener(*args, **kwargs))
File “/usr/local/lib/python2.7/dist-packages/cherrypy/_cpserver.py”, line 151, in start
File “/usr/local/lib/python2.7/dist-packages/cherrypy/process/servers.py”, line 168, in start
File “/usr/local/lib/python2.7/dist-packages/cherrypy/process/servers.py”, line 412, in wait_for_free_port
raise IOError(“Port %r not free on %r” % (port, host))
IOError: Port 8080 not free on ‘’

[29/Jul/2015:06:50:30] ENGINE Shutting down due to error in start listener:
Traceback (most recent call last):
File “/usr/local/lib/python2.7/dist-packages/cherrypy/process/wspbus.py”, line 235, in start
File “/usr/local/lib/python2.7/dist-packages/cherrypy/process/wspbus.py”, line 215, in publish
raise exc
ChannelFailures: IOError(“Port 8080 not free on ‘’”,)

[29/Jul/2015:06:50:30] ENGINE Bus STOPPING
[29/Jul/2015:06:50:30] ENGINE HTTP Server cherrypy._cpwsgi_server.CPWSGIServer((‘’, 8080)) already shut down
[29/Jul/2015:06:50:30] ENGINE Stopped thread ‘_TimeoutMonitor’.
[29/Jul/2015:06:50:30] ENGINE Stopped thread ‘Monitor’.
[29/Jul/2015:06:50:30] ENGINE Stopped thread ‘Autoreloader’.
[29/Jul/2015:06:50:30] ENGINE Bus STOPPED
[29/Jul/2015:06:50:30] ENGINE Bus EXITING
[29/Jul/2015:06:50:30] ENGINE PID file removed: ‘/var/run/mineos.pid’.
[29/Jul/2015:06:50:30] ENGINE Bus EXITED

It seems to be reporting that 8080 is already in use…are you installing the web-ui on a system already hosting something on 8080?

Are you also running it as root?

I suppose I’m a bit confused by the post. The log indicates that you’re trying to start the web-ui (and it’s running into an error), but also you’re saying that you can connect to the web-ui and try to start the server.

If you can connect to the web-ui, then I think it’s just a simple mistake of this particular part of the log not being relevant. What we can do then is focus on the Minecraft server itself.

What user are you using to start up the server–have you been making any changing permission-wise in the filesystem within /var/games/minecraft? Share the results of the following command.

ls -la /var/games/minecraft

Hey hexparrot! Thanks for the quick reply!

So I’m not running any other services on that port in either my VM enviroment or my host environment. As for the user permission, I always edit my backend in my VM using root and when I log into the WebUI I use the default MC account that the MineOS creates at install. I also did not edit anything in to do with perms in /var/games/minecraft.

So I can login to the WebUI using both root and mc, I can create profiles, I can create servers, and I can monitor my heap. It’s just when I try starting the server from the UI that is says “success” with a no start. The WebUI is running but when I type “service mineos stop” into the terminal it say the service is not running :S The confusing thing is, when I use " cd /var/game/minecraft/servers/servername/" “java -jar forge_universal.jar” the server boots just fine and I can login normally (with the exception of it not being tied to the WebUI).

To be honest, I’m almost 100% sure now that I’ve been tinkering for the last 20 hours or so, I have corrupted files in my debian subsystem. I have started using a VM as I was running MineOS from a solid state drive as a secondary master on my motherboard, which resulted in me only having the drive live about half the time. With how good 'ol solid states like to lose data during temp fluctuations I’m quite sure I’ve lost some data to do with the WebUI host. I’m starting to think this because of the kernel panic that happened a few hours ago.

I am going to do a full install of a fresh OS instead of the flash clone I did of the solid state and try again. I will also try checking the perms on the original build with “ls -la” once I’m back home tonight.

Again thanks for the help hexparrot! You are the reason why this community is so awesome! :smiley:

This, if run as root, would make it so many files in the “servername” directory are owned by root. Reinstallation will be overkill if you can just identify that there are files not owned by mc:mc…which is easily corrected.

ls -la /var/games/minecraft/servers/*

This is only going to tell us anything before you re-install! After you reinstall, the permissions will likely be corrected and we’ll never know the cause. If possible, do this first!

Hello hexparrot!

So I typed the command you asked and the read out showed that the server jar was owned by root on my machine.

I did go through with the restart of the OS as it is quite late at night right now and I wasn’t sure how long it would take to get a reply.

So on the fresh install I ran the Forge_installer.jar as root and moved the files it created to the proper folder. I then ran the server using the WebUI and user mc. The server started and is now running correctly.

It was deffinetly caused by me running the server_universal.jar as root before I tried running it as mc.

Although I have the corrected the issue, how would you suggest fixing such and issue without resorting to a full os install? Just for future reference :smile:

Again thank you very much for your help, I would have been stumped for a while and just did a restart without knowing exactly what I did wrong. Now I can avoid this issue in the future!

Should be just (as root):

chown -R mc:mc /var/games/minecraft/{servers,archive,backup}/*

Note: this command assumes there’s only one user who owns all the servers, mc:mc.

If you have multiple users, then you’d just want to chown them individually, e.g.,

chown -R mc:mc /var/games/minecraft/{servers,archive,backup}/hereisaservername
chown -R will:will /var/games/minecraft/{servers,archive,backup}/hereisaservername


You’re the best hexparrot!

Sorry to resurrect a month old post… Does this mean that with the exception of ‘servers’. ‘archive’, and ‘backup’, the other directories in /var/games are owned by root?