MineOS on debian 10 fails to start

So, I’ve installed MineOS on Ubuntu-Server 18.04 LTS once. But now I’m on Debian 10 and I can’t get it to start. First I tried mineos-node, and of course, it didn’t work. Awhile after I tried the systemd version. And yeah it didn’t work.

I’m sorry if my English is bad, it’s not my primary language :frowning:

Sorry if I missed anything!

Thank you!

Screenshots:
https://gyazo.com/5c28282e67a738c6ca1ee8d29033b491
https://gyazo.com/779645084413130fbd25045ab644b38e

(It’s also on bare metal, no Virtual Machines or virtual hardware)

If you can provide the contents of /var/log/mineos.log it will likely point out the specific issue keeping it from starting.

This could be a few things, from NodeJS’ version being too modern and some of the npm dependencies don’t get built, or it could be something less common. The logs will show us.

I didn’t find the mineos.log file. The only thing I found was in the supervisor folder.

mineos-stdout—supervisor-0wXzDp.log: https://pastebin.com/dU5VAcZZ

supervisord.log: https://pastebin.com/awWG3hku

Good thinking on the supervisor log:

Error: Cannot find module 'fs-extra'

This is the problem. This is a module that should have been installed already through the use of the npm install command. It probably failed; I’m guessing you’re using NodeJS version > 8.x?

Try this, as root

cd /usr/games/minecraft
npm install fs-extra

If you get errors, those are the specific errors we want to see. It probably will tell us that this module, which is definitely necessary, isn’t compatible with … Node10 or Node12…or something to that effect. Which tells us also that your NodeJS version needs to be downgraded (removed and specifically installing Node8)

The steps in all the wikipages should definitely have installed Node8, so that’s another thing I’m interested in finding out–why any other version may have made it onto your system instead.

1 Like

Well, when I run npm install fs-extra

I get -bash: npm: command not found

So isn’t it apt install instead? I just don’t want to screw anything up.

Apparently I’m running: node --version: v10.15.2

That might explain it then.

  1. Node 8 and Node 10 are pretty different, and dependencies aren’t expected to work from between those versions. Basically, it was like Node1 -> Node 8 which shared a common API. After Node 8, they took the years of things they learned and made a new one…think Python 2 -> Python 3. Similar in so many ways, but not enough to be inter compatible.

  2. So you potentially then, skipped this step, which adds Node8 repositories to Apt.

  3. If you didn’t do that step, apt will default to Debian 10 default repos which contain apparently v10.15.2.

  4. Default debian 10 repos keep npm separate, so that explains command not found.

So to remedy this:

  1. Using apt, remove node10.
  2. Using the commands in the wiki linked above, put the Node8 repos in as a download candidate.
  3. Using apt again, install Node8. The installed packages should clearly indicate the version is 8.
  4. Having used the Node8 repos, npm will be included automatically, and the npm install command would work.

isnt it apt uninstall nodejs?

apt-get remove nodejs

Alright, so I guess I did something wrong because when I ran:

curl -sL https://deb.nodesource.com/setup_8.x | bash -
apt-get -y install nodejs

It installed node 10 again. What do you mean with the “download candidate” part?

this is what I got when I ran the curl -sL command btw: https://pastebin.com/MJYK5C9S

Sorry if I got it wrong

Not sure why that didn’t work. The instructions for downloading node come from NodeSource.

It’s pretty straightforward that Debian 10 is supported and that Node8 should be a candidate, so I’m not sure why that didn’t work.

Supported Debian versions:

NodeSource will maintain support for stable, testing and unstable releases of Debian, due to the long release cycle a considerable number of users are running unstable.

  • Debian 8 / oldstable (Jessie)
  • Debian 9 / stable (Stretch)
  • Debian 10 / testing (Buster)

You might try the ‘manual’ installation steps outlined therein, or if they don’t look too appealing, just trying any distro that’s not Debian 10.


That said, looking into your actual error, it also appears there’s a way to circumvent the block on getting node8:

  1. E: The repository ‘http://http.debian.net/debian jessie-backports Release’ does not have a Release file.

  2. N: Updating from such a repository can’t be done securely, and is therefore disabled by default.

Disabled by default suggests there’s an override.

so, what would i even need node8 for? Is it for the npm feature thingy? Because can’t i get that with node10?

You can try installing node10 with npm, but if it doesn’t work, it’s likely you’ll see errors where dependencies don’t build properly–and the reason is likely the same as the one this user experienced.

Yeah, it seems to have created the files with /usr/games/minecraft blah blah blah, though it still doesn’t work ofc :frowning:

https://pastebin.com/zmNMUHie

So, the only fix for this would just be to change distro at this point?

The reason why Debian node10 gets installed instead of upstream’s node8 should be obvious for anyone who knows how version numbers work. :stuck_out_tongue:

nodejs:
  Installed: (none)
  Candidate: 10.15.2~dfsg-2
  Version table:
     10.15.2~dfsg-2 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
     8.16.2-1nodesource1 500
        500 https://deb.nodesource.com/node_8.x buster/main amd64 Packages

It looks like the nodesource folks fail to take into account the possibility of Debian/Ubuntu already having a newer version than the one they want you to install. This will affect any distribution released in the last year or so. This issue has been reported multiple times yet no one seems to be in a rush to fix this bug. One workaround is to use package pinning such that the older node8 gets preferred over the newer node10, either by boosting the nodesource packages, or deprioritising the debian packages.

2 Likes

Alrigt, I’m super excited because i just got it working with your link!

All I had to do is paste in some code lol! Thanks!!!

(i will se if it works by installing mineos on debian 10.2!)

Indeed it does! Thank you so much! You should rly make a guide for new people :smiley:

Hmmm… I think im detecting a problem… For some reason it don’t want to connect to the internet… It doesn’t show profiles

Nvm! Internet seems to be working now lol. Weird ¯_(ツ)_/¯

Sorry I’m spamming but im super happy rn, I hate Ubuntu-Server so much. And ah, yes, port forwarding has been confirmed working!