MineOS-node released on Turnkey ISO

It is recommended that you simply install the latest MineOS from the ISO and just import your previous servers.

By no means is this required, but my experience with the community at large shows that it takes less time and has substantially less room for error.

As a side note, of course you do not need the Turnkey ISO, just as before, the webui can be installed atop an existing distribution (but here, you just want to avoid the removal steps of the previous one).

Okay, so this could be a silly questions but I’ll ask anyway.

I’m currently running a Ubuntu 14.04 server ( For MineOS and Teamspeak3) I’d like to take advantage of the new features but I’m unsure if I would be able to install the MineOS-Node ISO.

Essentially, is the MineOS iso a completely different OS that will not allow me to run my Teamspeak 3 server?

Quite the opposite. The only thing changing here is the MineOS webui is the Node.js version vs the Python version. The underlying OS is 100% the exact same Turnkey Core; identical in all ways.

Awesome, thanks for the info!

Congratulations @hexparrot on the release of MineOS-Node!

I’m looking into updating the FreeNAS plugin, and here are my observations thus far…

  • npm-uname wouldn’t compile for me (trying this in a freebsd jail)
  • from poking around it looks like there is no longer a config file to set things like base_directory, webui port, or https
  • am I missing something?
  • will this functionality be added back in the future?

I installed the node.js version but it seems to have a glitch detecting that the server started. It always shows the server is down but it actually does start up. I can connect to the minecraft server. The server console log shows it’s started. Just the webui does not see it.

WebUI shows version 1.2.2

Doing the debug command:
root@core ~# cd /usr/games/minecraft/
root@core games/minecraft# ./mineos_console.js -d /var/games/minecraft ping_debug
throw new TypeError(‘Arguments to path.join must be strings’);
TypeError: Arguments to path.join must be strings
at Object.posix.join (path.js:488:13)
at new mineos.mc (/usr/games/minecraft/mineos.js:127:15)
at Object. (/usr/games/minecraft/mineos_console.js:119:16)
at Module._compile (module.js:460:26)
at Object.Module._extensions…js (module.js:478:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Function.Module.runMain (module.js:501:10)
at startup (node.js:129:16)
at node.js:814:3
root@core games/minecraft#

I’m having significant performance problems and lost ticks. Would upgrading to node help me alleviate these problems?

No, the webui should never really be a factor in server performance, so switching from one to the other should have zero performance impact on your servers.

You should instead look into what the bottleneck is–I/O? CPU? Memory & swapping?

I am unable to add multiple additional Java arguments.

This issue was identified and fixed in a recent commit that wasn’t on the ISO. If you update your scripts in git, multiple java arguments will be properly parsed.

Any plans or changes coming as a result of the release of node.js 4.0?

Checked and works under nodev4. Not yet pulled in all the dependency updates because it breaks it on FreeBSD. Waiting for the update of npm crypt3 and it’ll be full stable 4.1.0.

Does the new turnkey release FIX that bug where firewall entries were not saved in the system webmin? I recall having to actually manually write them to get things to work. I see the versions are the same in the new iso released.

I’d like to upgrade from my old mineos Turnkey to the new one but i’ve made a bunch of customizations to the turnkey and it just works. Is there a way to install the MineOSnodejs part only? It seems node-js is not a package for this older turnkey release.

I don’t know if it will work for you, but I went to the install docs for the python version and uninstalled it following the install directions in reverse. Don’t take any shortcuts and leave stuff because ‘it should be the same’, it isn’t. Then I followed the install instructions for node webui and it worked, brought up all my worlds, everything was good.

The only thing that didn’t come back were my old vanilla minecraft profiles and I don’t know how to add them back in but I was able to set the servers to the Mojang profiles and they are running fine.

Otherwise, this should work. I don’t know which instructions you should follow for Turnkey Linux - maybe Debian/Ubuntu? Perhaps someone else can answer that if you don’t know. I am running Ubuntu 14.04, and like I said it worked flawlessly.

Good luck! And make a backup before you start this - just in case! 8’)

EDIT: Based on Debian, so you should be able to use those instructions.

it seems the nodejs is not getable using the apt-get library for that turnkey version

I saw awhile ago somewhere but can not find the info now. How would I go about doing this? What are the exact commands I would type in to update the webUI (any any other updates to the OS that there may be)?

See the wiki for updating the webui.

And updating the OS would be through apt-get, which is a normal Debian/Ubuntu utility. Many guides and tutorials can teach you the very simple use of apt-get for keeping your OS updated.

Ahh already did the apt-get upgrade (and dist-upgrade), thought there was more to it than that. Thanks for the quick reply, I have also updated my WebUI now!

Where would you post changelogs, and how can I get notification of new updates?

There’s no release schedule–all changes just show up on the github commit list. The expectation is that it is always the right time to update…no changes are expected in MineOS to remove any functionality, so everything is pretty much feature addition and security/performance enhancements.