MineOS Node on Ubuntu 15.04 (It's smarter than I am.)

Hi Folks,

Back again… I’ve installed the latest version on a stable Virtualbox VM running Ubuntu 15.04. Actually I’ve tried several times now, the most recent one using the install script. The issue is that even though I’m not seeing any errors, and even though MineOS seems to be running, I can’t access WebUI. Please advise on how to troubleshoot… I’ve tried a lot of things at this point, but I’m game for trying things again!


What address are you typing in the browser?

Hi Heparrot. I’m using the local IP ( and port 8443, which is open on the Linux firewall. I also tried setting MineOS up for port 8888, and the service appeared to load successfully but I could not open it in Firefox on my laptop. I can access other services on the machine such as Apache and Webmin.


I’m seeing the same thing on a fresh install. Interestingly enough, the socket seems to exist and accept connections:

sudo netstat -natp | grep 8443
tcp        0      0  *               LISTEN      22066/mineos
tcp        0      0        ESTABLISHED 22066/mineos

But it seems no data is being sent over it.

By using https:// it works for me now.