Minecraft Forge 1.12.2 isn't Starting [Solved]

Hi guys, I have a problem that I’m sure is simple enough to solve, I’m just missing something.
I have only basic knowledge in Linux and MineOS, so simplified explanations would be greatly appreciated.

Anyways, I want to play MC with 1.12.2 mods, so I decided to create a forge server.
Note: I already have a vanilla 1.16.1 server that runs perfectly for some time now.

My steps:

  1. I downloaded the forge 1.12.2 recommended profile from profiles.
  2. Ran the forge installer jar file. That worked just fine.
  3. Now in my Profiles I chose 1.12.2 under the forge section. In Java settings I chose the forge 1.12.2 jar file.
  4. I expected it to run, but the server just starts and stops , it doesn’t stay up for more than I few seconds.

What I’ve gathered:

  1. There are no logs.
  2. Reading online, can’t find a solution but read that I might have to use openjdk 8. Is this true? Right now I’m using openjdk 11.0.8
  3. I’m running Debian (Raspbian)
  4. Even trying with the forge 1.12.2 latest profile gives the same result.
  5. I also copied the jar installer to my laptop and installed server it from there, and pasted the files back to the Pi. No luck
  6. No combination of profiles with java settings works.
  7. The minecraft_server 1.12.2 jar that is installed from the forge installer jar works great and the server boots and function normally.

Any help would be greatly appreciated. If I need to put any more information, just let me know.
Also I don’t know which category this belongs to so I’m leaving it uncategorized for now.

Edit 1: I’ve tried creating a forge server in 1.16 and it’s a success! So what’s wrong with 1.12?

Edit 2: If anyone ever reads this facing the same issue, the solution I came up with is indeed switching to openjdk 8. Hope it helps!

1 Like

Hey, having this exact same issue, hoping you will reply. How do you install openjdk?


It’s quite simple, I used this tutorial and it worked just fine for me:

It’s for the raspberry pi, but it’ll work on any Debian based OS.

1 Like

this worked for me, nothing 1.12 would run. i had java 8 installed and couldnt go any higher. i had to add the repo for 11 and once i got it installed and set 8 as default, everything works


I try to start the Forge 1.12.2 server on latest MineOS with JAVA 17 but the Forge 1.12.2- file will not start. I have there also Minecraft_server.1.12.2.jar.
Is there a problem with JAVA, that the old Forge release will not start on the newer JAVA or I have stared the wrong file?
The memory I have set correctly and added enough:

  • -Xmx 10240MB
  • -Xms 4096MB

Thanks for all helps.