Lost servers on WebUI

Hey everyone,

I’m a noob with MineOS but was managed to get a docker up and running rather quickly and a server running 1.9.4 for more than a week now. I was playing on the server and logged of to take care of something and literally 30 min. later the server is gone from the webui list. I setup backups and try to load the backup but get an error that that server name and info is already running, unfortunately I cant access them at all. I have looked for over two hours but I cant seem to find anyone with my exact issue as this is running on a Docker on unRAID 6. I created the servers with the default “minecraft” account and never had an issue until today. Can anyone lead me in the right direction as to what is going on here?

P.s. i would like to note that at the time of the error a new user tried to login to the server that i wanted to play with me so im nit sure if that has anything to do with it.

I have the log file but its too large to post here and it wont allow me to attach the file either.

Please help me get back online as this software has been amazing for me until this little hiccup. (fingers crossed )

Thanks in advance!!

When you set up your docker containers, what were the commands you used to do it?

Ordinarily, the location on your filesystem is specified right there, under the volumes argument: -v, which is /var/games/minecraft on your host system.

Hello,

The unRaid software I am running has a repository of pre-made docker containers of which I downloaded and installed the Mineos software. The only commands I entered were basic like where to save game files and server files, the latter I did not touch and left at /var/games/minecraft. See attachment for location of server files currently set. Those files, along with the Docker image itself are sitting on the systems SSD Cache drive in case that is important to know.

I hope you understand me here, this isn’t quite an OS like deb or ubnt rather unRaid is the host os and allows docker containers access to I/o when need be. The company has a repository of docker containers and it’s simply a matter of choosing which you want. Like an app store if you will. Even the setting are included in the images and only minor adjustments need to be made.

Please let me know if I further confused you, lol I know this might be a lot to take on.

Sorry!!! Forgot the screenshot :joy:

Google Photos

Hope the link works, lmk if not.

Thank!!!

According to your screenshot, it says it’s putting files that would go into the container /var/games/minecraft into /mnt/user/Docker APP's/Minecraft

Have you checked there?

As a side note, I also see from the screenshot it is using a MineOS hub image from yugiod, rather than an official MineOS-docker image. Is that your only option?

Hexparrot,

Look in the folder for what? What should I be looking for?

The folder has my mc server in them and if I navigate to them with a pc I can initiate a local minecraft server with the Java files in there and play a LAN game. In essence I’m making my laptop a minecraft server with the files on my unRaid 6 device and then also using the same pc to play the game.

I also see some log files like for users in mc and game settings. All seems ok to me but still no servers in mineos webui all thought mineos says the servers are running, which isn’t true unless I remotely access the files like I mentioned before but that’s not a function of mineos, or should I say no thanks to mineos.

Thanks for then help as usual!

Yes the app was in there. Search for mineos and it came up for me.

This is where MineOS would save files by default. When using Docker–under normal circumstances–this is also where the Docker volume will take files saved on the GUEST’s /var/games/minecraft/and make it accessible on the HOST at /var/games/minecraft.

This directory should contain the following subdirectories:

/var/games/minecraft/servers
/var/games/minecraft/backup
/var/games/minecraft/archive

Regardless of what’s going on with the webui, I recommend protecting your files by copying any current archives to a different machine (and if you want, your more current server directory).


With that done, the next question is: when you click the name in the top-right of the webui, it should show you what commit (mineos version) you’re on.

What does it say?

No, not if it’s a simlink (which it probably is) however it may produce issues when trying to interact with the directory via commandline, which can easily be solved by quoting everything;

For example: cd "/mnt/user/Docker APP's/Minecraft" will always work (unless of course the directory is invalid), while trying cd /mnt/user/Docker APP's/Minecraft may not, and is very likely to have issues without the quotes (being that there’s a space, and an apostrophe in the directory name as you noticed).

1 Like