Load averages and server startup problem

I have a problem. When I start a server, it is stopped during startup, and the average load increases to about 20. An hour later, the load average goes down to 0.25 and the server finishes booting. This happens once a day.

I have the latest version of Mineos Node.

mineos.log : https://hastebin.com/ugapiqureq.json

I really need help :’(

Do any of your servers generate mapping?

If you’re talking about a dynmap, no I do not.

So every time you start the server it takes a long time/has a high load average?

Let us know any information possible to troubleshoot this. What are the specs of your system? What server software are you running?

I use spigot 1.8.8. on three servers and bungeecord 1.12 on a server.

This is really weird because the server startup abruptly stops, the average load increases, an hour after it returns to normal and the server finishes to run.

The cpu of the vps increase to 100%

I have another problem, I do not know if it can help. The operating time is currently 6517:39:37. That seems strange to me.

I do not know what else to say.

If you’re not familiar with the utility ‘top’. Give it a look when you start the server. It’ll tell you what process is actually using up all this Processing power

Also, that means your server hasn’t been rebooted in 6500 hours. Perhaps that’s due. Update the webui to the most recent version, reboot your server and see if this behavior continues.

Many people run spigot but don’t have these symptoms so it’s easier to start with low cost, easy troubleshooting steps.

I used “top” : http://puu.sh/xwzgB/c0746b25a2.png

I already have the latest version of the webui and I tried to restart the vps but nothing has changed.

The uptime does not decrease despite the restart of the vps

I’m sorry, but I don’t think I quite understand the problem you’re experiencing.

What exactly is stopped, if it raises the load to 20?

And then the server finishes booting?

All that suggests to me is whatever server you’re running is requiring a heck of a lot of CPU time to load all the mods, and that there is no problem because it ultimately loads up as you expect.

if I have a vps with 16GB of RAM, how much memory can I allocate to the servers? Maybe I’ve allocated too much …

I would reserve 1 GB to the OS.
This gives you 15 GB to split between you minecraft servers.

I would make sure that the total amount of RAM given to all servers do not exceed the total ammount of RAM available. So if you have 15 GB, you can have 15 servers with 1 GB each, one wiht 15 GB or a mix inbetween somewhere… As long as the total do not exceed physically available.

I have tried going above, and had mysterious crashes as a consecvence.

I changed the memory of the servers:

bungeecord : 3072 Mo
spigot server : 3072 Mo
spigot server : 3072 Mo
server spigot : 2048 Mo

but it has not changed, the problem still exists.

I executed the command “free -m” to know the remaining memory:


Your problem is still very unclear to me.

What we’re dealing with here–since you confirmed via top that Java is being started–is a Java/Minecraft issue.

However, you’re saying “when I start a server, it is stopped”–but it clearly is not being stopped. The process itself is open and using memory, using CPU.

what is the actual issue you’re having?

Because load averages are not a problem (at least not how you’ve described it). If a server starts, then it’s working, right? What isn’t working?

I will describe what happens:

I restart the server. First, the server starts up normally (everything goes well in the console and the average load is 1), then, the server stops starting (the console does not display anything, the average load increases gradually to about 20 or 30). Finally, about an hour later, the server continues to boot and starts completely (the logs of the console resume where they were, the average load gradually decreases until reaching 1 approximately).

of course, with the other servers, the plugin that is shown here in the logs is not the same.

And just to confirm, everything starts up and actually works?

Does this happen with any other servers that aren’t spigot? What serverpack are you running?

Keep in mind, the MineOS webui simply shows what Spigot produces to the logs. If Spigot doesn’t produce new lines, MineOS rightlyfully doesn’t show anything new.

If your server load increases, it seems like that’s easily attributed to something Spigot is doing. Do you see this as an issue outside spigot?

If you think Spigot is at fault, we’d need to know more about what you’re running–we still don’t have any idea what serverpack you’re running. Perhaps this is by-design from spigot?

After every restart, even if it is long, the server is functional, even if I notice big lags (but this may not have anything to do).

I will restart the bungeecord server to test…

the three spigot servers use spigot 1.8.8. I do not think it could come from spigot. I do not understand what is “serverpack”.

Well, I could download spigot, and it won’t have Vixio. Vixio is a plugin. A collection of plugins makes a serverpack.

Okay :wink:

I just think of something. I use skript on my servers and skript takes a very long time to start knowing that Vixio is an addon skript.

Otherwise, globally:
Practically all the skript addon

EDIT : I restarted the bungeecord server. It started correctly in the console but I can not reach the server, and the average load has started to increase.