Let's Encrypt for the MineOS WebUI

Hello everyone!

Has anyone been successful in using Let’s Encrypt in SSL? I’ve been able to get it working for Webmin, but can’t seem to get it working for MineOS and Shellinabox.

I tried changing the configuration file for MineOS, but for some reason it has no affect.

Any help is appreciated!


What files have you generated from letsencrypt? And how did you adapt that for mineos.conf?

Did you also restart the webui after making those changes?

I generated two .pem files. One being letsencrypt-cert.pem and letsencrypt-key.pem. I tried going to the mineos.conf file and changing the directory to the two .pem files, but it wasn’t working for some reason.

I restarted the WebUI by using supervisorctl command. (supervisorctl restart mineos)

Well, based on what I’ve seen/noticed in the past (about a year ago) MineOS uses it’s own pem files (they’re standard pem files, just renamed as mineos.pem) so maybe that could help you…you can try replacing those files (keep a backup just incase).

Unfortunately, this really doesn’t tell me what you did in mineos.conf, so I can’t really provide any insight about what might have gone wrong or what to do differently.

Did starting the webui fail? Did it succeed? Did it produce anything to /var/log/mineos.log?