Legacy Minecraft versions

Trying to make a server for older legacy Minecraft versions specifically 1.4.7 atm. For some reason i cannot connect to the server and i recall having this problem with these older versions in the past but cannot recall what the issue is or what the solution was.

Everything is within the local network and i can see the server over lan.

Trying to connect to the server gives me this error

I have gone through the various logs to see what the issue is and i am not really sure as everything looks to be normal. I have also tried starting the server in offline mode.

The only thing substantial i can see is which is just dc spam in the Minecraft console. Like i have looked at system level logs and not much is said. Without going and looking one of them had similar spam in it but i cannot recall of the top.

2022-05-25 18:13:52 [INFO] / lost connection
2022-05-25 18:17:24 [INFO] / lost connection
2022-05-25 18:18:30 [INFO] / lost connection
2022-05-25 18:26:10 [INFO] / lost connection
2022-05-25 18:26:20 [INFO] / lost connection

I have several servers/test servers so i know that this is an isolated incident with this older version.

i needed to type the local ip of the host server instead of just trying to connect via local host
the thing is this is the very first thing i tried after the standard way of connecting did not work and i literally tried that like 20 times at least but with no results. Checking if the port was listening and looking at other relevant areas which all seemed to be fine.

Very strange one of those moments where one is not sure what the issues actually were because everything was checking out. Maybe i was typing incorrectly? but 20 times lol? and even after cross checking an even further ctrl+c the local ip for the server from the router map???

Idk tbh. I Just now decided this is my last attempt so i decided to try deleting most of the directory for that instance except for the relevant files like the server jar and the server conf/s. Booted up the instance waited for it to propagate the files and remake the world etc typed in the physical ip for the server and it connected my player straight away.

Something to do with the routing on versions pre 1.7 are coded differently i am not entirely sure. Being that 1.4.7 is old i have not played it since 2013 and i have never actually made a server before for these old versions.