KCauldron Really Slow, Supported?

I have been trying to get a KCauldron server going for my community, i built a modpack and tested the server to make sure it works fine, and it does. i tested it on straight up ubuntu with no issue what so ever and also on windows with no issue, now when i load it on the mineOS on Ubuntu server 14 distro it runs incredibly slow, so slow i cant even put commands into console. can’t do perms or anything, had to resort to doing perms on my PC instead of through the webUI. if there’s a fix id appreciate the information/help.
Sorry for working with an ancient server release that’s no longer supported anyway.

I’ve personally used Thermos which has worked fine/great, though I’ve not really done anything MC-specific in awhile but based on research I’d still probably have to recommend Thermos over KCauldron based upon things not being much different now compared to back then. Anyways, your PC vs the server has completely different hardware and software (I’m assuming) so depending mainly upon the hardware and all the mods in your modpack it may/might not be able to keep up from what I can tell, the first things I’d say to try however is ensuring the web ui is up to date, and telling a bit more about the system (hardware wise) and modpack. Also server logs may help, if you’re getting “can’t keep up” messages that’d be a hint to the hardware not being able to keep up or run fluently/decently with all those mods.

The current hardware installed is a ASUS p8h61-M with 16 GB of ram, Intel I5-3470 125GB ssd 750 GB HDD.
i’m giving the server 5GB of ram, only uses roughly 2GB when fully up and running.
There is no cant keep up message

basically my modpack consists of terrafirmacraft, fastcraft, FTBlib, FTButilities inventory tweaks, waila, wawla, NEI and a mod to assist players with tfc within NEI. the only mods installed on the server are FTBLIB FTBUtilities and Terrafirmacraft. the rest are not needed because they are client side and would have no effect on the server except for just slowing it down.

the server works perfectly fine with spigot, had a 7 server deal held together with bungee at one point and would max out at 10GB and it wouldn’t phase the cpu which was nice.

As for a log, give me a bit, i was messing with scripts to find a workaround for this issue and it ended up breaking all network bits within ubuntu so i have to reinstall ubuntu and get it all set back up. it will take me anywhere from a couple hours from this post up until tomorrow.

Well, I’d probably likely say to go with Ubuntu 18.04 now rather than 14.04 or 16.04, and the only other thing I can think of at that point would be installing Oracle Java over OpenJDK as mods seemingly just tend to work better and crash less that way according to other posts here.

i actually switched to ubuntu 18.04 just before i read this. its still running slow so my guess is the talk between the webui and kcauldron is a bit slow, im ganna go hunt down thermos and try that out.

Well, it shouldn’t be slow I don’t think, but here’s Thermos


just tried thermos but when i joined the server crashed and gave me this, if your willing to help find a solution to it here’s the pastebin [21:29:15] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FM - Pastebin.com


EDIT: found the fix but now runs like kcauldron, at least i can input commands now.

Alright i gave it a day, doesnt run well either

Well, this one’s probably likely gonna be a tough one then, I can only say from my experience that everything has always worked fine/great and smooth and all and that it was all with/using Thermos, I’ve stopped playing on that server for 3 years kind of sort of and when I finally checked the system I saw I had half my storage used up and traced it down back to logs for that particular server taking up all that space running for a few years (on and off since I started using the system for other purposes) with no gameplay related activity like joining or anything like that. The only other thing I can suggest to try and figure things out and dig a little deeper to pinpoint whether it’s your system configuration or the server/modpack is since I have a working environment that has worked for a really/very long time would be providing a server archive or an archive of all the mods you want to use on the server and I’ll see what I can do, if I get it working and it all works for me and I return the archive and it’s broken or doesn’t work for you then it’d be a system configuration thing and if I can’t get it working then it’s a modpack thing.

Actually, before that, question is, which version of Java do you have installed and currently in use, OpenJDK or Oracle Java? I’d recommend going with Oracle Java over OpenJDK or if you’re using some other version of OpenJDK that is not OpenJDK8 then I recommend switching to OpenJDK8 or Oracle Java 8, mods overall based upon many posts here tend to run better and crash less and whatnot with Oracle Java 8 but it will all depend upon what you have installed currently exactly.

im using openjdk8 ill try oracle java and if i need to ill pop in an archive

this is the link to the server ill remove this when all is said and done
as for the pack if you need it

Alright I have no idea what version of Thermos you are currently using (couldn’t identify it using hashsums so I couldn’t verify other required portions were what they were supposed to be) or how you fixed that crash on join (never experienced that before) but copying/cloning some of my configurations over I was able to make it a bit more responsive and last longer (tested with/by using the rtp command and checking performance), my system’s nowhere near being close to matching yours (significantly less powerful processor that’s also much older and significantly less memory) so it still ended up freezing running out of memory and crashing in the end but it at least lasted longer. As for the web ui portion, starting the server typically requires refreshing the browser in order to make the web ui become responsive again after the server is up and running, known thing with logs spitting out or accumulating tons of lines per second. Also, the pack is incomplete; you can’t join the server with the pack. I copied the files from the server to the client to overcome that for testing.

yea rtp seems to have issues so i may just remove it, as for not being able to log into the server with the pack i have no issues and neither does the players, as for the build its build 53

Yeah probably replace it with a better “smarter” more customizable rtp plugin or something, as that could help make it better since the only way I was able to lag or crash it was with multiple rtp. And so then you pretty much fixed the crashing on join issue with a much older build which is why I wasn’t able to identify it as I didn’t check that far back.

yea i read on the forum about having issues with more modern builds, as for the rtp plugin ill keep an eye out for something, the one i had wasn’t that popular which i regret not getting a more popular one. anyway i appreciate your help and patience.