Issues setting up MineOS

I don’t know if I’m doing anything wrong as I’m fairly new to Linux, but when I try to install MineOS as outlined on the Wiki, I ran into an issue with the “install npm” command, where it told me I/it doesn’t have permission to access something. I had root access and tried doing sudo su and re-entering the commands, still didn’t work. I decided to skip the step, and then after trying to access the webui, it said [my ip address]: refused to connect. Just yesterday when I tried to set it up on another computer, the webui came up, but when I typed in my name and password, it just reloaded the page and I was stuck in a loop. Since I’m new to linux, I don’t know where to find the logs, but I will try to find them if needed.

This is the part you should share with the post, so that we know what you typed and what error you got in return.

This is almost never going to be the correct answer; in the future, take note of the errors you run into because that’s what we need to help.

It was at this step that I got an error. When I am able to access my computer, I may provide an image or screen recording of what I typed in and exactly what was happening in the terminal

If it’s coming from the terminal, it’s always preferred to get a copy-paste, rather than an image. It should be more convenient to post, too; it certainly will be easier to read.

I mean while it’s still doing stuff, and when there’s a progress bar. Sorry I’m new to linux so I’m sorry if I sound like I have no idea what I’m talking about, but I will copy and paste the final output as well as screen recording what’s happening in the terminal. Also, does doing it from SSH/RDP matter? I don’t think so, but I tried doing it on the actual computer instead of remotely to see if it would fix it, but it didn’t help

I found the path of the log file, but I can’t find any answers on Google how to actually get to the log file, because it keeps saying that I don’t have permission since it’s in the /root directory

Nevermind, I got it fixed, but the weird thing was I had to give myself root access by modifying some kind of file