Issue starting Spigot server

Totally new to MineOS and even Minecraft for that matter. But a long time Unix/Linux IT guy.

Trying to use MineOS to setup MC server for child that plays it way to much and hoping to teach him some IT stuff out of this.

Setup MineOS no issues and got a vanilla MC server up and running without issue. Now trying to figure out how to get a Spitgot server running.

Using the nice GUI under Profiles I downloaded this:
BuildTools-latest Latest BuildTools.jar for building Spigot/Craftbukkit

Then went to Create New Server and tried both conventional and “not conventional” options but neither works for me. Tried different potions for the selected profile including BuildTools-latest and well as one of the 1.8.x variants from Mojang. I guess I am confussed here as to what Profile needs to be used. It would seem from the Minecraft game on my son’s PC he only has Mojang type profiles. Does this mean he would need to have this Spigot/BuildTools-latest on his PC as well to get this to work?

It would not seem to matter much as when I start it either dies right away or sometimes a jvm stays up and running but I don’t see any new port being opened up and LISTEN on.

It is also unclear to me what to have listed under Java Settings for the jar file I have tried a number of combinations like BuildTools.jar as well as one of the Mojang jars but nothing helps.

I searched around the forum and could not find enough information to help with my question here.

Thanks for any help!


In the menu for spigot / craftbukkit:
Did you press the button “Build spigot” for the version of spigot / craftbukkit you want to use? (you need the 1.9.2 version to work with the latest version of minecraft for PC)

After the build successfully completed, did you press the new button “copy to server”? This copies the file you just made to the server you wish to use.

After this you do not really need to choose a profile in the server controlls, the jar should be available under the pulldown menu.

The server is a conventional server (unconventional means “do not use” and only goes for a few spesific server types, like bungeecord and to some degree pocketmine).

For java settings, the default is just fine.

For a bukkit / spigot server your son do not need anything more than the stock minecraft client.

Yes I had done the “Build spigot” and Copy to Server before. I now noticed when I retried that it said it failed for 1.8.9 as that his the version my son said he wanted to be playing on. I could only get 1.9.2 to biuld so I am now trying that one.

When I tried to start it at first it was erroring out with some error about needing to define the jar. I under the Change profile to: I had selected spigot/BuildTools-latest. After a few tried it did come up and says it is up and running but I still don’t see it Listening on 25565 as it says it should be from the Dashboard. There is no log file created at least in the GUI or even what I can find on the server. There are strangely two jvms up and running. I know when I had the vanilla version running I only saw one jvm up and running.

mc@core servers/testspigot$ ps -ef|grep java
mc 18718 1 0 15:29 ? 00:00:00 /usr/bin/SCREEN -dmS mc-MCSpigot /usr/bin/java -server -Xmx1024M -Xms1024M -jar BuildTools.jar nogui
mc 18719 18718 8 15:29 pts/4 00:00:40 /usr/bin/java -server -Xmx1024M -Xms1024M -jar BuildTools.jar nogui
mc 23467 18719 99 15:36 pts/4 00:00:17 /usr/lib/jvm/java-7-openjdk-i386/jre/bin/java -Xmx1024M -classpath /var/games/minecraft/servers/MCSpigot/apache-maven-3.2.5/boot/plexus-classworlds-2.5.2.jar -Dclassworlds.conf=/var/games/minecraft/servers/MCSpigot/apache-maven-3.2.5/bin/m2.conf -Dmaven.home=/var/games/minecraft/servers/MCSpigot/apache-maven-3.2.5 org.codehaus.plexus.classworlds.launcher.Launcher clean install


What do /var/log/mineos.log say?
If you SSH into your MineOS, is /var/games/minecraft/servers/[servername]/logs/latest.log there? And what do it say?
Have you tried connecting a minecraft client to your server? Does it succeed?

There is no log created and there is no logs directory under this newly created server either. I have not bothered trying to connect as I know there is nothing even up and listening.


I asked about two logs:
/var/log/mineos.log <-- the main log for the entire MineOS system
/var/games/minecraft/servers/[servername]/logs/latest.log <-- spesific log for the single minecraft server

Since the last one is missing it is, as you say, most likely that the minecraft server haven’t startet up properly the first time.

BUT: You just answered me forone of the logs. We still need an answer to what /var/log/mineos.log say? We usually need the entire log to be able to help, as it is not always self evident what is causing an error.

Sorry yes I did look at /var/log/mineos.log and I did notice something strange where when I tried to start the MCSpigot server it said it was trying to start the other vanilla one I had created and got working earlier. So I remembered seeing a “supervisorctl stop/restart mineos” command and I did that. Then I deleted MCSpigot started over. This time when I started I noticed under the Java Settings the option to use “spigot-1.9.2” as an option. Sure enough that did it.

I believe I am good with this question. Thanks for the quick help.


1 Like

Related to this question however is I wanted to try and run the “Build Script” under the “Spigot/Craftbukkit” menu with an older profile “1.8.9” but it keeps erroring out. I seemed to work part way and created the profiles/spigot_1.8.9 directory with a lot of stuff in it but not the final spigot_1.8.8.jar file.

It would seem to me that at the top when you click “Download latest BuildTools.jar” you only get the latest which is 1.9. Would I be correct in assuming I have to go out the Spigot website and see if I can pull down an older 1.8.9 version of the BuildsTools.jar to get this to work?

Thanks again!


Well. The errors of 1.8.9 can be explained with the lack of build tools for 1.8.9:

Spigot jumps from 1.8.8 to 1.9.
If I remember correctly version 1.8.9 of the minecraft client could connect to 1.8.8 servers, so Try with a 1.8.8 instead of 1.8.9

@hexparrot: Could you mask out 1.8.9 as a choice in the spigot / craftbukkit menu please, since it do not exist.

Unless there’s a systematic way to know that a given version can’t be built, no, unfortunately that’s not possible. Otherwise I’d have to save it/micromanage the lists…which means it could very much fall out of sync on a great number of users’ systems if they don’t update their webui files often.

I see our point. I’ll look into finding a method to test for working versions of buildttools vs minecraft versions. It would be nice to be able to not offer versions that do nt exist as well, since (as in this case) it generates users trying to make them and failing.

I don’t think a 1.8.9 jar for Spigot was ever released, that could be the problem. it went from 1.8.8 to 1.9, i know i was in the same situation.

Opps… just saw Imelsom’s post. sorry

1 Like