Installing MineOS while booted into another OS


I am somewhat new to Linux and would like to be new to MineOS, really like the whole idea.
However, I have problems installing MineOS and only get the error “Unable to find a medium containing a live filesystem”. I tried on 3 different computers, and I also tried regular Ubuntu Server, but get the same issue everytime. I am sick and tired of trying different BIOS settings and USB sticks etc.
My idea:
Having the destination harddrive plugged into another Computer (Windows 10, Manjaro or Ubuntu 18.04 would be easy, as they are installed), installing it inside a VM that has the harddrive allocated and then just swapping the harddrive into the destination Computer.

Here is the catch, I never used VMs and have no idea of what even to search on the internet. Can you guys help me? Is this a smart idea or complete bullshit? :smiley:


Making an image on a VM the applying it to a physical box may be more problematic than you are looking for. The drivers in linux is file based and isn’t as easy to “swap” builds like that. You can use a VM solution and simply run it on whichever physical host of your choice. For that I recommend Oracle’s VirtualBox. It’s free, simple to setup and robust.

As for booting up from a live disk… some USBs drives may have multiple portions and not set to actively boot. Might have to scrap the portion table completely and rebuild it. I haves tried SD cards in a long time, but I believe that they won’t boot unless the BIOS allows it.

Welcome to the community!

I like the idea of what you want to do however, you would be severely bottlenecked by the read and write speed of a flash drive.You would be better off having installed with the MineOS.iso which is built with Turnkey or you can have it installed with a different OS like Ubuntu Server and that’s what I’m using.

When I was experimenting with using VMs and hosting Minecraft servers with MineOS, it would lag really badly with it given 20gb of ram and 8 cores to play with all on a raid 0 SSD.

If you want to try using Ubuntu Server again, just do a fresh install and follow these instructions to installing MineOS.

What are you using to host a linux distro that you are getting these issues?

I found out how to fix it the way I thought. Wanted to kind of explain how I did it. Please let me know, if I can make some kind of guide out of this, otherwise, feel free to copy my explanations and make one yourself.
I used Windows 10, you might have to adapt stuff for different OS’s.

This method it somewhat dangerous and may lead to data loss! Be careful!

Step 1:
Install VirtualBox. For me, I had to use an older version (4.3) as mounting a complete harddrive to a VM is forbidden by Windows 10 in newer releases.

Step 2:
Plug the harddrive in a spare SATA slot in your computer, but boot to your normal OS.

Step 3:
Open Disk Management on Windows (As an Admin user) and note down the Disk number you want to mount. I follwed this guide a bit, it has screenshots:

Step 3:
Open a console (Run as administrator)
Change Directory to Virtual Box. Standard installation folder is following command, adapt if neccessary:
cd C:\Program Files\Oracle\VirtualBox
VBoxManage internalcommands createrawvmdk -filename “D:\VM\drives\mydrive.vmdk” -rawdisk \.\PhysicalDrive3
Adapt the PhysicalDrive3 to whatever drive you noted before. Also save the file whereever you like by adapting the path.
All data on this drive will be lost! Be warned, take the wrong drive and you might fuck up your day!

Step 4:
Open VirtualBox
Add the image for MineOS to the CD drive and click the button for adding a harddrive, choose existing and load up the previously created file.

Step 5:
Launch the VM and proceed with the installation. I chose the guided option without the LVM, as LVM didn’t work for me.
Be sure to let it install the GRUB bootloader, as you won’t be able to boot the OS from another Computer otherwise.

Step 6:
Shut down the computer, take the drive with MineOS out and put it into the PC you want to run MineOS. Start the computer. It should now simply boot into MineOS (Might have to change bootorder).

Feel free to ask me questions.

1 Like

Thank you.

I don’t know what you mean with a USB bottleneck. I run a normal SATA harddrive, that I put into the other PC.

The computer I used as the Server is an old Fujitsu Esprimo with a Core II Duo, Therefore I want to have it use as few ressources as possible and run as headless as possible.

This may be just a one off, but at least you documented it in this thread so others can search for it, if needed.
Great job at sticking to it and lab VirtualBox worked.