Installing a modpack server using MineOS

Hello! I’ve been wandering around this forum all evening trying to find a fix to my issue… Long story short, I want to play a modpack on my own server, but when I think I’ve done everything correct, the server starts… then stops :frowning:.
For some prerequisite info, I installed MineOS overtop of ubuntu, so I can’t get into my MineOS webui without using my root (as far as I can understand), I have tried running the forgexxxintaller.jar, but I don’t get a universal.jar out

I’m so tired and I have absolutely no idea what to do at this point… please help :frowning:.

run the command

java -version

you want java 17 for 1.19 and webui is using java 16.


apt-cache search openjdk

Just looking quickly on the package browser online i can see they have openjdk17 for the latest release

Just install 17 and leave 16 for the Webui. Use the server.config file to point to your openjdk17 jar once you download it.

You should be able to use mc or any other user that is not root to access the ui. You may want to look at this as Webui is a nice front end of the whole setup without it it makes the whole thing kind of pointless. You also don’t want to be doing stuff as root unless stated and you definitely don’t want to run servers as root.

I’ve installed Java 19

I just retested it, and a vanilla 1.19.3 server works without issue. If that’s working could java still be an issue?

I’m not super familiar with Linux, is the original login I made when setting up my ubuntu server the same as root? or no? Because I use that login I created to get into the Webui. But none of the other users that I have created work to login, it just erases the text boxes and does nothing.

Oh, also, I found the universal jar, it was buried in a bunch of directories, so I copied it and the server.jar into the server dir, and now it’s an option for me to select when choosing the jar in the webui, but unfortunately its still not working :frowning:

You need to update the java arguments. Search for my posts on no targettable jar.

Thank you sir!! This fixed the issue completely!