Install Java 8 on MineOS Turnkey

So I’m trying to get a minecraft server running on an old PC with a 32-bit architecture. I installed MineOS Trunkey from the link found here :
I selected the “Previous 32-bit ISO download”. It works fine, I’m able to login to the webUI.

The first problem I encountered was a download problem (error 403) for the minecraft versions in “Profile”. I managed to fix that by manually downloading the jar file on the official website then uploading it on the server with WinSCP. I can then select the correct .jar file on the server settings.

The second problem is that for the newer versions of minecraft, I need at least Java 8 for the server to work. The pre-installed version on the ISO is Java 7. When I run

java -version

I get

java version "1.7.0_95"

followed by OpenJDK Runtime etc.

First thing I did was to run apt-get update and apt-get upgrade as root. I then tried to follow this tutorial. However I’m stuck at the first step and get the error message

E: Unable to locate package libasound2-data

My knowledge of linux is close to zero, sorry if I miss obvious things. Thanks in advance for the help !

EDIT: I tried running a 1.11.2 server to see if there was another issue, but it worked just fine.

You’re attempting to run commands meant for Debian 10 (Buster) on Debian 7 (Wheezy).

So you might instead use instructions like these, tailored for Debian 7:

Thanks for the answer. Everything went fine until the last command:

apt-get install oracle-java8-installer

I got a similar error:

E: unable to locate package oracle-java8-installer

My guess is that the ppa of webupd8team is discontinued, I read it while I was searching for a solution before coming here. Is there any other way I can install Java 8 or a newer version ?

MineOS Turnkey is literally just Debian.

In this case, you’re just using an ISO that corresponds to Debian 7. So if the instructions linked above don’t work (perhaps if webupd8team’s repo is discontinued), then literally any other way to get Java on Debian 7 will still work.

For example, you can also follow the instructions straight from Oracle:

You will additionally want to add to your $PATH variable the path for your installed oracle, so it is found first, rather than the system version.

Keep in mind, order matters for the path variable! Do this for both root and your non-root user.

1 Like