Importing from Turnkey to a WebUI on Ubuntu

About 1.5 years ago, I created a server using the Turnkey ISO and 2 vanilla Worlds (one in creative mode and the other in survival mode) for my kids and their friends. I can’t upgrade the vanilla Worlds to version 1.8 because the Turnkey server doesn’t support the new EULA so it’s now stuck at Minecraft version 1.7.9. The kids and their friends want the latest version, so to fix this situation I creased a second physical server with Ubuntu 14.4.1 LTS and the latest MineOS Web-UI. To test the Ubuntu WebUI I successfully created a new Minecraft world with vanilla180 and I also managed to successfully Import one of the two vanilla 1.7.9 World from the Turnkey server.
The problem is with the 2nd vanilla179 server from the Turnkey server. It isn’t reporting any error during the import process but the users are not appearing at the right locations and when a user is teleported to a known location, the buildings are gone and the lay of the land is different.

Anyone as any suggestions?

Thank you

Have you tried updating the web-ui since installing it?

It’s meant to be regularly updated, so that the update that addresses the EULA can be used whether a fresh install or an older install.

Also, even if you didn’t/couldn’t do anything about the EULA from the web-ui, you could always do it the way all other Linux-based Minecraft admins are, by editing /var/games/minecraft/servers/yourservername/eula.txt directly:


Doesn’t require the web-ui to be up to date, but is convenient to do so.

Thanks for your tip. Nearly 6 months later and I finally had time to work on the turnkey server today. Adding the eulat.text file worked to get version 1.8 to work.