Importing a world into FreeNAS MineOS?


I just recently upgraded FreeNAS to 11 and in the process of doing the upgrade lost my Minecraft world so instead of starting with something totally blank again I thought of importing a world I happen to stumble upon while on YouTube.

YouTube Video / World Download for those interested…

I managed to get the files into the MineOS Jail by first renaming the existing world folder found in
/mnt/MYVOLUME/jails/mineos_1/var/games/minecraft/servers/Myserver/world into old_world
I then created another world folder into which I downloaded the file straight from the net using the wget command and unpacked it using the unzip command.

Other than that I didn’t change anything else and low and behold it’s not working - Attempting to start the server ends up with a Myserver down message - Comparing the world folders ( picture below ) gives me the impression that I’m either missing some crucial files/folders present in the old one or is there a setting that needs to be adjusted to get this working?

Thanks in advance!
Durahl =)

I can’t imagine there being a setting that would be relevant here. After all, if the new world’s files are simply not matching what they used to be, it seems a straightforward case of the transfer not having done to completion.

I haven’t used FreeNAS, but that shouldn’t impact what I’d advise to do.

  1. ensure the zip file actually has all the files it should have from the original world (it doesn’t).
  2. put the complete, correct zip file in /var/games/minecraft/import–or in FreeNAS’ case: /mnt/MYVOLUME/jails/mineos_1/var/games/minecraft/import
  3. use the webui to import the world.

But the biggest takeaway here is that your World Download zipfile does not appear to have the files from the original, so even though your wget/unzip method would have been just fine, it appears that’s not the main issue anyway.

Hi, I run my mineOS instance in freeNAS as well, though I’m using a fresh iocage instance instead of the official plugin, as the plugin is (as of this writing) still based in warden, which will be deprecated as of the next major release (and IIRC the warden plugin had some issues regarding outdated node installation anyway).

It looks like that .zip file doesn’t contain any .jar files at all; I’m assuming you’re copying them in via the webUI? Missing .jar = no server executables.

Additionally, check that all the files are owned by mcserver:mcserver. If you’re not inserting the files via the jail’s console it’s highly likely they’re owned by root:wheel. The ensuing bad permissions are probably gonna give you a hard time (I had the same problem two weeks ago).

As an aside, I’d highly recommend that you not store your Minecraft worlds within the jail. I created a separate dataset at /mnt/MY_VOLUME/games/minecraft, which is then mounted into the jail at /var/games/minecraft. This allows minecraft server instances to survive completely independently of the jail, which gives you more flexibility. If you ever have to nuke the jail for whatever reason, server data will remain intact. You can then just mount the dataset into the new jail and pick up from exactly where you left off with no further configuration necessary.

Argh… I must have skipped the reply notification email - Sorry!


  • Is there a tutorial available how to install mineOS using an iocage? My knowledge about Linux/FreeNAS is rather… limited.
  • Can the missing Jar files be recovered by using another worlds files or am I out of luck with this world? What in particular is missing?
  • Files were imported into the Jail using its own CLI so I guess I should be safe regarding that?
    In my first attempt I simply tried to swap out the folders but then attempted @hexparrot’s suggestion which didn’t work either - Most likely due to the missing Jar as the UI did manage to import something - Just not starting it.
  • I was actually hoping for such a feature to exist that would allow me to store worlds outside a jail - I’ll be having a closer look at the provided link.


There are a few tutorials, but there isn’t a UI available for managing iocage jails until 11.2 is released. If you’re not 100% confident in setting it up and diagnosing any problems entirely via the command line it’s probably better to just wait for that. There will be an official MineOS plugin for iocage in 11.2, so you can get around to upgrading then. (Also, if it’s working for you, why spend the time fixing something that isn’t broken?)

If you have the files mounted outside the jail, upgrading will be even easier. Just re-mount the dataset back into the same place in the new jail and you’ll pick up right where you left off.

You should be able to import just the necessary server files via the webUI. When looking at the server status, there will be an option to select the server’s profile, i.e. the server software/version being used. Select the appropriate profile and hit the “copy to live server files” button. This should insert the .jar and relevant files into the directory.

Found this while looking around for the same problem i currently have i attempted to do the following above but it states that i need an empty Directory so it will not allow me to mount it, for now im stuck not having my world that was running on my person PC on my MineOS jail in Freenas. any ideas why this would be?

I am in the same boat as @Klessc. How do we create a mountpoint to games/minecraft when FreeNAS keeps saying the destination directory must be empty?

In the past I have tried to do a couple of things.

The first time I tried mounting this I used the console to delete the folders below the minecraft folder. Then I made the mount point and then I started up the jail and created my first test server. If I remember correctly this actually worked. But later on I broke it somehow, probably when I had to replace a drive in the pool and didn’t know what I was doing.

The second time I just made separate datasets and mount points to each folder below the minecraft folder. So I had a total of 5 subdatasets below my MineOS dataset that became the mount points of each of those folders in the jail. The problem I ran into there is the permissions wouldn’t allow my windows machine to do anything I wanted to do in those folders.

So I am once again jumping into the breach as I try to find a good permanent solution to the problem of MineOS mount points and windows shares.