I have tried, Cannot accpet EULA ageement. 1.18.1

hello, I am trying to set up my vanilla minecraft server. I do apologize, I am fairly new to this. I have tried everything I could find on here, but to no avail. I am having an issue where when I try to start the server, nothing happens. I either get a message of “start failed server may not be up when preforming this action” or the server starts briefly then shuts down. I have looked around and it seems the webui should prompt me to accept the EULA but it does not. I have tried editing the file through /var/game/minecraft/servers/[server name} but I either do not know how, or am doing it incorrectly. please help.

You might not have the most up-to-date version of java. There are posts here about updating.
1.18+ requires Java17.

thank you. I appreciate the help I an having trouble still updating the java version. can you please point me towards the correct thread. I did find one that was for updating to java 16.0.1 but that is running natively on the server. i tried just using the wget for the Java 17.0.1 but i get an odd error about usr/bin/java : File exists. I saw someone else had this issue in that thread but it didn’t really get answered

nevermind, thank you for your help. i figured it out. and learned some things along the way. once again, thank you

1 Like

Hey you could write out what you did/figured out, to help people in your situation in the future

yes, my apologies, I had to update the Java version. i used the steps here: Upgrading to Java 16 from the MineOS Turnkey ISO

i just replaced the link in the “wget,” line with: https://download.java.net/java/GA/jdk17.0.1/2a2082e5a09d4267845be086888add4f/12/GPL/openjdk-17.0.1_linux-x64_bin.tar.gz

and any mention of 16.0.1 with 17.0.1. I also had to modify the last line from:
“ln -s /opt/jdk-17.0.1/bin/java /usr/bin/java”
“ln -sf /opt/jdk-17.0.1/bin/java /usr/bin/java” because the usr/bin/java already existed for the -sf make it get overridden. I hope this helps anyone in the future.