I had problems starting a 1.13 server on FreeNAS, but i fixed it!


#1

Hello!

I just installed MineOS in my FreeNAS server, and i found out fast that i was not able to run the lastest version of minecraft (1.13)

Tried a few things in this forum but this is how i made it work:

pkg install wget
mkdir /var/games/minecraft/profiles/1.13
cd /var/games/minecraft/profiles/1.13/
wget -O minecraft_server.jar https://launcher.mojang.com/mc/game/1.13/server/d0caafb8438ebd206f99930cfaecfa6c9a13dca0/server.jar
cd /var/games/minecraft/servers/[MYSERVERNAME]/
wget -O minecraft_server.jar https://launcher.mojang.com/mc/game/1.13/server/d0caafb8438ebd206f99930cfaecfa6c9a13dca0/server.jar
pkg install openjdk8
edit /etc/fstab
Add this:
fdesc /dev/fd fdescfs rw 0 0
proc /proc procfs rw 0 0

Restart jail, and it should work.

Then just run the server again, and it works :slight_smile:
Hopefully this helps you guys.


#2

didn’t work for me i put it in as plain text


#3

What errors did you get?


#4

i cant install openjdk8 it give me the following error:

Updating local repository catalogue…
pkg: Repository local load error: access repo file(/var/db/pkg/repo-local.sqlite) failed: No such file or directory
pkg: file:///usr/ports/packages/meta.txz: No such file or directory
repository local has no meta file, using default settings
pkg: file:///usr/ports/packages/packagesite.txz: No such file or directory
Unable to update repository local
Error updating repositories!

if you can fix this let me know as soon as possible
thanks


#5

Best guess is you haven’t yet initialized the ports directory (/usr/ports).