I can't join my server over the internet

Hello, I can’t connect to my server from over the internet. I can connect via LAN or on my own network but just not on a outside network. I have done port forwarding to the computer and I’m pretty sure the port is open on the router. I have tried connecting with the IPV4 address. I’m using the google wifi mesh network.

Hm, are you using MineOS Turnkey or MineOS installed on an Linux Distro?

I’m using MineOS Turnkey from the wiki.

Hm, does the server have a static IP or an automatic one? Like, when it asked you to put in IP details did you choose automatic or did you type a custom, for example: IP adress, DNS, Gateway… etc…?

Or do you have no idea what I’am talking about lol?

I thought it was on static but I didn’t type any IP address or DNS stuff.

oh well, then I recommend entering a static one, and use an IP with like for example: so it doesnt conflict with DHCP which it usually would for me. And I also recommend using as DNS since its pretty much the fastest

Okay thank you! How do I do this? Does it matter what IP address I give it?

As long as the ip isn’t used by any other computer than it doesn’t matter.

No, but It usually would replace my IP with another one even if I had a static one. I guess my DHCP was kinda fucked, so it’s much better to use an higher one on 192.168.1.x so it doesn’t get occupied

Sorry for the long response

I don’t actually know how to do it on Turnkey “since I use MineOS installed on Debian”

Though I think you need to press “advanced setup” when you’re in MineOS, after that “Network setup” or “set static IP”. I’m not so sure, though you can do some quick exploring

I don’t think it worked. I gave it an IP reservation through the google wifi app. I also checked the IP adress of all the devices connected to our network. None had the exact IP I gave to the computer running the server. For testing I connected a computer to my phone’s hotspot. Thanks for the help so far.

Just opened port 25565 on my phone and checked to see if it’s open on this site: https://canyouseeme.org/ it says the port isn’t open with error “connection timed out.” I opened the port, why does it say this?

That’s because you need to go on your router and port forward the port to the servers ip. When you use sites like canyouseeme, they send a packet to your ip but your router doesn’t know where to send said packet. That’s why you get connection timed out.

Edit 1) Just realizing that you said you connected your server to your phones wifi, I don’t think you can port forward on your phone. Though to be fair, I never needed to so I don’t know.

Edit 2) Port forwarding is an advanced network feature that is not supported through the Mobile Hotspot on a smartphone due to the restrictions of the gateway you mentioned.

Edit 3) I found this: https://support.google.com/wifi/answer/6274503?hl=en

Edit 4) I assume you were able to boot as your having issues connecting to your server outside your network.

I’ve already port forwarded the server pc. Before, I meant I connected a pc (running a Minecraft client) to a hotspot to connect to the server pc to see if it works.

Try using https://mcsrvstat.us/ to check if your server is on the internet.

My server doesn’t have a domain yet.

ismyportopen.com is much better. mcsrvstat is just slow and unnecessary

You would type in your public ip address like to give an example.

Also @Rover all the site does is check if the mc server is connectable through the internet. I don’t see how it’s slow and it’s very necessary.

My servers up! It turns out I had another router from my isp which was the problem but now I disconnected the router from the modem and plugged it in directly to google wifi. Mcsrvstat reports it’s up.


Yes, it checks if it is connectable, which is what mcsrvstat also does, though its just does it slower