Hwclock issue?

I ran “hwclock --localtime -s” thinking that would change my Minecraft logs and restore points dates, for some reason they seem to be off by 4 hours and nothing I do seems to make them sync up to my timezone. At command line when I type hwclock the time is correct.

Do a quick search for changing time zone. It’s something like dpkg-reconfigure tzdata. Hopefully this helps.

I tried to correct my time using “dpkg-reconfigure tzdata” at the end no matter what I choose the UTC and localtime don’t match, neither does the UTC and GSP. I guess for me to get my Minecraft logs to match my times would be to change which cock it uses.

Usually it is a feature in the BIOS, but you should check that your hardware clock (as far as the BIOS is concerned) is set to UTC. If you’re telling Linux your server has HWCLOCK to UTC, but it’s local, then you have your Linux set to local timezone, there’s going to be a bit of discrepancy.

  1. check your bios’ time. Set it to UTC (by changing the numbers and checking UTC time)
  2. hwclock -u -s
  3. Then make sure your timezone is A-OK in Linux.

If you really don’'t want BIOS UTC time

  1. check your bios’ time. Set it to your local time.
  2. hwclock -s --localtime
  3. Then make sure your timezone is A-OK in Linux.

hwclock man page.

  1. BIOS time is set right
  2. hwclock -u -s is what I set this too
  3. my timezone is set to New York which is the correct timezone.

My dates are still wrong on my restore points, archives and logs

no matter how I set this hwclock it does not change the times on the log entries. All I want is to read the logs and have correct time so I know if it happened at midnight not 5am. My guess there is something not right with how mineOS reads the hwclock for the times to timestamp the logs.

have you restarted the server since changing the clock?

yes every time I made a change to the hwclock settings

Are you saying its not changing the timestamps of already created files?

If so, yhen that’s as you should expect. A file labelled or log timestamped for Jan 1, 2015 0:0:0, for example, will never be any other time…

If youre saying it’s not changing recent entried (since changing the clock),

Let us know what “bios time is set right” means. Local or utc.

no, the new ones being made are still five hours fast

Edit /etc/adjtime
Change “UTC” to “LOCAL”
Worked for me.

Please let us know what you’re actually doing.

BIOS time is set to my local time. I tried setting it to UTC time also but still was wrong. After reading a page the UTC does not do daylight savings time, I want to use Localtime now since the hardware clock will account for daylight savings. I know no matter which one I set the hwclock to it does not effect the Minecraft logs, so I must be using the wrong commands or missing a step in the process.

Here, if you were setting BIOS to local, but using -u, then you’re using local time, but telling hwclock "I’m using UTC’.

Look up a few posts for instructions. Commit to one. Local or UTC. Whichever you choose, use those instructions.

Sorry it took me so long to get this set right, but I found a site which explained it so I was able to see the errors of my ways, Thanks for the help. I set the hwclock to local

  1. I used “dpkg-reconfigure tzdata” to change my timezone via command line
  2. hwclock -u -s to set hwclock to local time
  3. reboot server to check BIOS to make sure the time was set to correct localtime.