Howto install Pocketmine on current MineOS?


#1

Hi there,

I am using MineOS in a vmWare virtual Machine for my private Modpack (playing with my children). Now the kids also want to play Minecraft PE so I went looking if this can be done with MineOS.

I read many threads here and it seems that pocketmine is the way to go. I read the instructions from early 2015 and found this hint in one post:

For MineOS-node this means there won’t be any need to go outside the web-ui. It can be downloaded and servers created all within the webui from the first time it starts.

I updated Mineos-Node via the convenience scripts, so I am running the latest version, I assume but I cant’t find a pocketmine profile.

Before I start messing with php installation (I am an IT guy but work mostly on windows) I just wanted to ask if this is still the way to go or how to activate the profile for pocketmine.


Proxmox MineOS VM not accepting local client connections
#2

Can anybody confirm if Pocketmine is still working with current versions of mobile Minecraft?

The last Pocketmine is pretty dated according to the official webpage:

The build 1266 using API 1.13.1 was released on Sat, 19 Dec 2015 23:41:43 GMT

By the way, sometime in the last few months, maybe longer, it was reported that something starting going awry with Pocketmine, which I believe drove me to remove the profile from in the webui.

That said, Nukkit I believe is a current Minecraft: PE version, which is in the webui.

Also, as a heads-up: the first time you run Nukkit, it requires interactivity: you have to choose the preferred language. This may mean you’ll need to start it up as mc from the command line prior to using the webui.

(alternatively, you can connect to the screen instance as mc via screen -r)


#3

Apparently version 3.0.0 Alpha 8 is working with MC PE 1.2 version:

Source: https://forums.pmmp.io/threads/is-the-current-build-of-pmmp-stable-for-1-2.4028/

I haven’t tried it so i don’t know for sure.

I have tried installing Nukkit and i selected the language (could be done from the MineOS Gui). Server is starting up

2017-10-15 14:25:19 [INFO] Loading nukkit.yml…
2017-10-15 14:25:20 [INFO] Loading server properties…
2017-10-15 14:25:20 [INFO] Deutsch (deu) als Standard eingestellt
2017-10-15 14:25:20 [INFO] Starte Minecraft: PE mit Version v1.1.3
2017-10-15 14:25:20 [DEBUG] Timings:
Enabled - false
Verbose - false
History Interval - 6000
History Length - 72000

But I can’t connect via Minecraft PE from my iPhone or Minecraft Windows 10 Edition from my server. The server is starting on port 19256 (at least I set it in the web gui). And added TCP and UDP access for this port in iptables.

iptables --list
Chain INPUT (policy DROP)
target prot opt source destination
ACCEPT all – anywhere anywhere
ACCEPT tcp – anywhere anywhere tcp dpt:ssh
ACCEPT tcp – anywhere anywhere tcp dpt:8443
ACCEPT tcp – anywhere anywhere tcp dpt:25565
ACCEPT all – anywhere anywhere state RELATED,ESTABLISHED
ACCEPT tcp – anywhere anywhere tcp dpt:19256
ACCEPT udp – anywhere anywhere udp dpt:19256

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

I don’t know where to look …

The iPhone is in the same network as the MineOS Server.


#4

They did a restart and moved to PMMP.
Jenkins to latest release: https://jenkins.pmmp.io/job/PocketMine-MP/
Jenkins to latest release of precompiled PHP for pocketmine: https://jenkins.pmmp.io/job/PHP-7.2-Linux-x86_64/

I install poketmine manually by adding files manually.

Before I start messing with php installation

No need for messing to much;) . They have precompiled php installations you just copy into your server directory and unpack (tar -zxvf [filename] ). Just follow the php link above to download