How to update?

Hi how do we update the node web ui as i can only find the update script for the python based one

Or is it done the same way?

regards

Scalda

Because of the dependency on npm for node modules, updating is done with a few extra steps than required by the Python webui. As root:

cd /usr/games/minecraft
git fetch
git pull
npm install

Right now, this works relatively smoothly, because the npm dependencies don’t change much, but they can, and someday might change a lot. What this means is that in the future it might be necessary to manually restart the webui process after all this. And the problem there is that depending on your chosen installation platform, this could mean restarting it with supervisorctl, service or systemctl, etc. Not that that is a hard thing to do, but it is simply not the same for all users in all cases.

2 Likes

from my reading through docs I don’t think the “–all” flag does anything. I think it assumes all unless you specify a package.
also there’s ‘npm update’ which forces updates when new versions of dependencies come out, but I think ‘npm install’ works just as well.

I’m not even sure where I got the --all from. Maybe it was valid when I was working on v.6, or maybe I just picked up garbage from wherever. I agree it doesn’t seem so useful to keep around now.

npm update I think does something else–I think it will update package.json, according to the semantic versioning. I’m not sure I have my versioning in package.json perfect enough to try that one out yet.

EDIT: the --all was to download the dev modules in addition to the normal modules. This is unnecessary for pretty much everybody except myself.

2 Likes

I am running Ubuntu 14.04, and had installed the python web ui originally. I reversed the steps to uninstall it and then installed the node web ui as I had recently discovered it was available. However I did not change my update script which was:

cd /usr/games/minecraft
git fetch
git merge origin/master

Everything claimed it was updating. When I came across these postings, I naturally realized I needed to update my script to what you have above. Now when I run the script I get the following:

$ sudo scripts/updateMineOSWebUI.sh
Already up-to-date.
npm WARN package.json daemonize2@0.4.2 No repository field.

For the python based web ui, you had a script to reset the scripts in case of error, do I need something similar in this instance?

Also, would it be possible to have the current version and maybe even the repository version showing so we can visually see our version and update status? I love the interface and maybe some more info to clutter it up a bit more would be fun!

Thanks!

Merge takes the most current updates to the script and applies it atop your existing scripts.

git reset --hard origin/master

Reset does exactly what it did even for the old webui, which is discards anything in your git repo that isn’t part of the official upstream repo (e.g., user changes, accidental or deliberate).

And regarding the current version:

Excellent, thanks hexparrot! I will try the reset and see if that fixes the error. As for 'git commit , I am ashamed that I did not look more closely…

I have checked the ‘git commit’ line after the vm rebooted, and it was not showing the version, that is why I did not see it. I stopped the vm, and went through the reset procedure to get ‘npm install’ to work and still no joy:

# npm install
npm WARN package.json daemonize2@0.4.2 No repository field.
# npm --version
1.3.10

So I did a complete reinstall of the web ui - deleted:
/usr/games/minecraft
/usr/local/bin/mineos
/etc/minos.conf
/etc/init/mineos.conf

and then reinstalled. Everything seemed to go smoothly except start and stop would not find mineos, so I rebooted. Everything came back up normally and start and stop both work. However, I sitill don’t have a version number showing:

That is all I have ever seen since I upgraded to the node web ui. Any thoughts?

EDIT: set preformatted code to code selection.