How to install Skripts/Get Spigot working

Essentially title, how would I go about adding skripts into a server.

From the skript documentation:

Download
To install or update Skript, download the latest Skript.jar and save it in your server’s plugin directory. If you’re installing Skript for the first time, start & stop your server once to generate the config files and some example scripts.

If this isn’t enough, let us know exactly what you’ve tried and what happened vs. your expectations.

Alright, still being very new to Linux in my UHC ( the name of the server ) server there is no plugins folder. So I want to know how to add that, I know how to get to the UHC folder but don’t know how to add files. After that, How do I download or put the file into the plugins folder through the terminal?

As for the Spigot thing, here is exactly what I do.

  1. I make a server ect setup everything load it up.
  2. I then shut it down and download spigot for 1.8.9
  3. I copy the files to the server.
  4. I then choose the BuildTools.Jar and load up the server.
    From there, the server will say its up but the Start/Stop buttons will not do anything and the server isn’t actually up.
    I also noticed if I don’t pick any .jar or the 1.8.9,jar the server will load up all find and dandy, assuming, without the jar file would this be the working version?
    Oh also when I press start [IJHC] start failed Server may not be up when performing this action

Only typing this because I want to bump it and my post must be 20 characters long.

I do believe you are choosing the wrong jar here.
This is how I install craftbukkit (spigot follows the same guide):

  1. open the “Spigot / cratbukkit” menu
  2. Press the button to download the latest build tools
  3. Press “build spigot” next to the version you want
  4. wait untill finished (you can see a status window at the bottom)
  5. When the buttons show up beside the version you chose, press “copy to server”, and choose the server you want the jars copied to.

Then you choose the freshly made spigot or craftbukkit jar (namedspigot-[version].jar or craftbukkit-[version].jar

Builttools are only used to build the necesary files, and thus will not work or start up as a game server.

1 Like

@iMelsom’s instructions are right on; this is the prescribed method.

Note, depending on which version you’re planning on building, e.g., 1.10.2, make sure that profile is downloaded from the Profiles page, from Mojang.

Ran this just now. To fill in some details, it produced spigot-1.10.2.jar, which I selected from the Server status page (for spigot servers, you do not need to choose a profile, as it is already present from the ‘copy to server’ step.

From here, it started up just fine and it automatically created the plugins directory which you can drop in your plugin jars into.

1 Like

https://www.youtube.com/watch?v=DSV4rb_1CH0&feature=youtu.be[quote=“iMelsom, post:5, topic:1405”]
Then you choose the freshly made spigot or craftbukkit jar (namedspigot-[version].jar or craftbukkit-[version].jar
[/quote]

Didn’t work, Made a quick video showing what I did.

But you are still trying to start with build-tools.jar, not the compiled spigot or bukkit jars.

Could you SSH int othe server, and check what files are placed there? You should see the necesary jar files in that directory.

You could also try to copy the files over again.

You also need both Xmx an Xms filled in, Xms should be about half of what Xmx is.

If selecting the correct jar do not (for some reason) work, you can also edit in the correct jar in server.config in the server driectory. This is really a last resort.

I know I was still choosing that, was just showing that the spigot folder wasn’t there.

I can SSH into it, though how would I find out if the correct jar files are in there? Don’t quite understand linux to good yet but can more than likely figure it out.
I’ve tried copying the files over multiple times.

SSH into the server. Use the following commands:

1. cd /var/games/minecraft/servers/UHC
2. ls

In you ssh windows you should then get a list with the contents of your server driectory.

Amon all the other files and directories you should see the folowing files in that list:

  • craftbukkit-1.8.9.jar
  • spigot-1.8.9.jar
  • server.config

Since you wish to run a spigot, it is the spigot-…jar you want to be there, but the copy operation will copy both of them.

since your server (by some reason or another, @hexparrot?) isn’t populating the server jar list in your server you can edit your server.config manually. If you do this it is vitally important that you do not touch the jar dropdown menu when you start the server, since this will overwrite any thing you enter manually. Even if looks like there is no jar chosen.

To do so do do this:

nano server.config
behind "jarfile=" enter "spigot-1.8.9.jar" (or the name of the spigot jar you found above, the names MUST mach)
press ctrl-x
press y
press enter

then go to the MineOS webui and press start on your server. Again: Do not touch profile or jar-selection dropdown even if they are empty! MineOS will try to start the server with the information in server.config

There isn’t a spigot file…

Oh wait…
I think this is an old error: There never was made a spigot version for 1.8.9 (https://www.spigotmc.org/threads/minecraft-1-8-9.107939/). Therefore when you press build, it do not build it.

See also this older thread tha tdiscuss the same issue you are having: Issue starting Spigot server

Try 1.8.8 or 1.9.0 instead. There where only minor client changes between 1.8.8 and 1.8.9, so the 1.8.9 clients happily connected to 1.8.8 servers.

Sorry for not catching this earlier :slight_smile:

1 Like

Oh my goodness this feels so much better. THANK YOU SO MUCH
Anyways, do you know how to put plugins into the plugins folder?

You stop the server, then use a ftp client to copy the plugin files to your plugin directory.

then you stat the server again, then stop it again. This is done to let the plugin generate any files it needs, like config-files. You stop it again to be able to edit the config of the plugins. If you wish to run the plugins as is, you do not stop your server.

if you need a ftp client take a look at filezilla: https://filezilla-project.org/