How to create personal minecraft modpack

Hi guys I have tried to make a server using mineos turnkey. I used universal.jar of forge 1.7.10, I put my mods folder in forge server but it doesn’t load the mod!

MineOS only starts the server with the simple java command. However, because it’s a front-end, it often makes troubleshooting more difficult. I recommend the following:

  1. log into ssh/the console as the non-privileged user. (often this is mc but basically it’s whoever the name logged into the webui that isn’t root).
  2. cd /var/games/minecraft/servers/servername
  3. java -jar universal.jar

Basically you’re starting the server manually. It’ll let you see all the error output and test it more responsively. Once it works this way, you can then return the webui to have that manage it from there on.

Exception in thread “main” java.awt.HeadlessException:
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
at java.awt.GraphicsEnvironment.checkHeadless(
at java.awt.Window.(
at java.awt.Frame.(
at net.minecraftforge.installer.SimpleInstaller.launchGui(
at net.minecraftforge.installer.SimpleInstaller.main(

this is is the log i can’t understand…

The error is telling you that whatever you’re attempting to execute actually is expecting to run on a monitor with a desktop. This is not common and isn’t the normal way dedicated Minecraft servers are run.

For example, vanilla minecraft can be run simply as a headless jar, or it can run with a GUI (point and click interface that appears on the desktop).

For obvious reasons, dedicated servers need not have their resources used to display the server on a desktop. It could be that you downloaded the GUI version of your Forge software. Or maybe it needs just a simple Java flag to ensure it doesn’t open with the gui. Vanilla, as an example, uses nogui to ensure that the gui doesn’t pop up.

Check if there are any java flags necessary to suppress the gui or if there is a different jar for forge you should be using.

i have used universal.jar --installServer is wrong?

i have to use universal or installer jar? for exemple -jar universal.jar --nogui ? or something different? i can’t found a nogui jar version

i think i have a problem i tried with forge from forge site --2019-10-07 20:22:43-- Resolving (… Connecting to (||:443… connected. GnuTLS: A TLS fatal alert has been received. Unable to establish SSL connection.
this is an error can someone help me?