How to connect to the web-ui from a different local computer

Hey there, I have my web-ui on a dedicated desktop that I plan on putting somewhere away from my monitors, I have tried accessing the web-ui from a different computer on the same network and it just says connection refused, I don’t want to have disconnect and swap cables everytime the server needs to be turned off/restarted.

Your server running MineOS should give you the address and port to connect. Should be something like https://ip:8443.
How did you build your server and what is it running on?

I’m running MineOS from the iso image, the first pinned thread on this forum. As for accessing the website, I just put https://localhost:8443 and it works perfectly

If on the local machine i put https://ipaddress:8443 it works, thats on the actual system, if i do it exactly the same on another local machine it just stay’s loading until it takes too long to respond, i have tried with google chrome, safari, firefox and none work.

Is your server running on a VM? Has there been any changes to the iptables? Describe the build a bit more?

1 Like

If you have installed MineOS from the ISO on a dedicated desktop, I see no reason why https://localhost:8443 actually works, to be honest.

Using that address means a) you’re using the same machine as MineOS as the browser which is odd because b) there is no browser that exists on the MineOS ISO because c) there’s no GUI and definitely no chance a CLI browser will work with the webui.

Can you explain better the set up you are using?

There is no vm, it’s on a dedicated machine, the .iso that is on the forum has Firefox and the os is WattOS, localhost:8447 works perfectly on the dedicated machine, but I want to access the web server from my laptop, when I put its ip:8447 it says connection refused

The os that was on the forum before is now deleted, it was a pinned thread

Let’s make sure we understand the setup. You are running a ‘nix OS and booting up the live MineOS in that distro. Then connecting to the MineOS from another device?

If that is the case, then you will need to have the ports opened in the iptables in the WattOS. Make sure you have 8443 and the Minecraft server ports (E.G. 25565) to allow traffic to pass.

localhost is the same as and is assigned to the lo interface. So pretty much is just passing data through the network interfaces.

Me and my friends can connect to the server fine, the iptables are not configured automatically? If so, I will do that, I will let you know if it works

The user previously said they were running from the MineOS ISO, which definitely didn’t have a browser and therefore nothing should be from local, it should be from a networked machine.

But evidently that’s not really whats happening here, there’s other OSes in play, such as the WattOS later mentioned.

By changing the iptables and accepting 8443 it started to work, I can now connect from my laptop to the web interface without needing to connect my mouse and stuff to the server.

I dont know what i downloaded but its working. At the beginning i tried downloading the iso from the website, but it doesnt work, it says “failed to find a medium containing a life file source” or something similar, so i went to the forums and found another iso file, i ran that and thats what im using now, its wattos and firefox is installed and other programs, that may be because on the installation screen i decided to install everything, so everything else is now working perfectly.

I found the iso and thread where I downloaded the iso: Updated Beginner-Friendly version of MineOS-Node (distro)