How do I start the webui?


#1

I’ve searched everywhere, through the docs, and through the forums, and I haven’t found anything telling me how to start the webui. I’m using the newest ISO of MineOS Turnkey, and I’ve tried to open the webui on my other computer but it doesn’t seem to start up by default. I’ve run “node webui.js” un /usr/games/minecraft after updating the webui, but to no avail. Could someone walk me through the steps I need to go through to open the webui?


#2

In the Turnkey / ISO versions of MineOS, the webui comes ready configured, and the WebUI should all ready be running.

To open the WebUI on another computer you need to point your web browser to the address:

https://[your MineOS Servers IP address]:8443

Please note both https (more specifically the “s” on the end of https) and :8443. Both need to be included in the address to be able to connect to the WebUI.

As you have a fresh install, updating the web UI is reccomended: https://minecraft.codeemo.com/mineoswiki/index.php?title=Updating_the_Webui

Please also note the “IT’s not working!” page for more tips on resolving errors: https://minecraft.codeemo.com/mineoswiki/index.php?title=It’s_Not_Working

As Turnkey really is a streamlined Debian you can read up on starting / stopping the webui under the debian page: https://minecraft.codeemo.com/mineoswiki/index.php?title=MineOS-node_(apt-get). At the bottom there is instructions for "Running the MineOS Web Service ".


#3

The issue is, I’ve tried to connect through https and port 8443, and it doesn’t connect through my browser. I’ve been able to connect to the host through SSH though. Ive already updated the webui as well. Also, the “It’s not working!” Page doesn’t have any information that would be helpful to me.


#4

What was the full address you put in your browser?

I’ve run “node webui.js” un /usr/games/minecraft after updating the webui, but to no avail.

Did you get an error? Because if you started the webui like that (which is not the way that that is prescribed: the wiki details this), then the webui is in the foreground. That also means that if you’re able to type anything in the console (SSH/terminal), then you’ve already closed the webui.

Starting it up like shown in the wiki makes it run in the background. This is actually the default, and the Turnkey installation should already allow your webui to open automatically, without having to start it up with this command.

Can you provide the contents of your MineOS log? /var/log/mineos.log


#5

I managed to get it to work by reinstalling the node.js webui through the Debian tutorial