How do I fix my modded minecraft server "I dont have an universal jar"

i tried to make a modded minecraft server but can find the universal jar

What have you tried? Is it a forge server?
There’s been a lot of discussion recently regarding forge servers.

yes it is a forge server I tried running the minecraft server.jar but its just vanilla Ive also tried running the forge jar but nothing happens

Have you read the other threads?
What version of forge?
What version of java?
the universal.jar (if this version of forge creates one) I found a few levels deep into the libraries folder.
is there a or other .sh in the server folder?

yes I have read them forge-1.12.2- and no i havent found anything with .sh

so, what version of java are you using?
the installer probably didn’t run due to having the incorrect version. I suggest you find out which version you need (by google) and install it then try again.

do I need jre or jdk

i have java 8 which i need

Make a forge profile The top yellow box is unnecessary but also notable

im not using mineos at the moment and Im on 1.12.2

was just an example that is just the page you need to use to make a profile all versions are on there.

I found a fix thanks anyway it was the forge file all along

Yeah it was. Hence why i told you to make a profile with the recommended forge that you need.The other half of the information i omitted because the forum was acting up and not allowing me to submit that information in the form of more pictures.

Essentially you can just make a profile which will download the forge version for that profile then when you go to run your server select that profile and it will start. There is even an option that says “copy live profile” on the instance page for any given server. Meaning that it will copy over the forge universal file to your actual game server directory for you.

Basically it can all be automated from Webui. I was trying to relay this in my previous post but the forum kept acting up so i only posted half the information because it was pissing me off.

Or you can just transfer it over manually which i am guessing is what you done.

1 Like