How do I access my MineOS server files? (to install plugins)

Full disclosure, I am brand new to anything NAS related… So if I haven’t provided all necessary details to help solve the problem I’m facing, please let me know.

I recently installed FreeNAS-11.3-U5 on an old pc that is no longer in use. My main goal in action was creating a minecraft server. After everything was booted up and I created a pool, I installed the MineOS plugin.
This all works great, however, my wish is now to create a papermc server and install plugins like mcMMO. My research has shown that to do this I must have access to the server’s directory, though I don’t know how to get to those. I would also like to keep the current world file, otherwise I would have just tried installing everything from scratch.

I have tried creating a user that has access to my entire freenas directory and accessing the files using Windows Shares (SMB). But when I do, it simply creates a new user directory. What I mean is that when I add a user and try to set its home directory to /mnt/Server (“Server” is the pool I created), it creates the directory /mnt/Server/[user]. I feel like this could be the reason that I don’t have access to the /var/games/minecraft directory. Should I have added a user before installing the MineOS plugin?
I have also tried using FileZilla and opening the directory using shell, but without success.

If anyone could help me gain access to my minecraft server files, I would be extremely grateful.