Hosting a pre-made Forge server, mods not working

java.lang.RuntimeException: ./config/CodeChickenCore.cfg (Permission denied)

Are you using the same account when trying to start the server to the account you login with into filezilla?

Try deleting that file and try running the server again. That config doesn’t do anything special.

I just changed it from “mcserver” to “games” which should have permissions.
Deleted the file you suggested, and the server has stayed up, is at 1.76GB memory footprint with no one connected, and I cannot stop the server (it’s refusing). When I try to connect locally, I get an IO exception error, but when I try again, it says “Server is still starting!”

I notice that your pack uses 1.5-1.8 gb idle. It will take abit of time to start on a 775 dual core cpu. And yes, you can’t stop it when its still trying to start.

But since it hasn’t crashed yet, I think you have it.

1 Like

So just let this run for a while and eventually I should be able to join? When looking into the io exception, it seemed like it was a NAT rule issue, though I’ve done it before for port forwarding for the Minecraft server. Would it be anything else?

Yes. Everything should be fine as it’s still loading. You’ll get those errors when you try to join and it’s still loading.

Last modification to the files on server side was at about 20 minutes ago.
Logs here:

You removed flans mod. IMO, I never got flans to work on a multiplayer server anyway so that’s for the best.

Add “-Dfml.queryResult=confirm” to the end of the jvm argument.

1 Like

Java arguments: -d64 -server -XX:+UnlockExperimentalVMOptions -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=3 -XX:NewRatio=3 -XX:SurvivorRatio=3 -XX:TargetSurvivorRatio=80 -XX:MaxTenuringThreshold=8 -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+ExplicitGCInvokesConcurrent -XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=60 -XX:+BindGCTaskThreadsToCPUs -Xnoclassgc -XX:UseSSE=4 -Dfml.queryResult=confirm

Jar arguments: nogui

Logs here:

Well that usually worked for me. But what you need to do instead is remove that addition and basically wait until you see that popup in the log window or if you don’t see any additional updates. That’s when you would type “/fml confirm” to allow it to continue.

I would set a timer for 6 minutes and then type “/fml confirm” in the log window or check box the This is not a conventional Minecraft server and type it in there.

Then when you input that you can uncheck the box.

It seems to be up, but from client-side it’s kicking me for not having all of the mods I believe.
[21:25:34] [Netty IO #1/INFO] [FML/]: Attempting connection with missing mods [bunch of mods]
[21:25:34] [Netty IO #1/INFO] [FML/]: Rejecting connection CLIENT: [bunch of mods]
[21:25:34] [Server thread/DEBUG] [NotEnoughItems/]: Unloading Player: [me]

At this point, I think I just have to wait for someone to test it other than me and if it doesn’t work, then I don’t really know where to go from there.

Thanks again for all of your help in troubleshooting this, you were extremely helpful!

Logs after someone tried connecting:

The only thing I could find that might help is to get all of your mods from one source like curseforge and have the most up to date version of your mods list. Either that or the dual core is not enough to host for you.

Alright, I think I’m just gonna call it quits. Thanks for all of your help, it’s greatly appreciated!

No problem. Have a better rest of your day.

1 Like