Help running FTB server

I had trouble getting everything up and going at first, I’m a very big novice with Linux, my issues at first was just trying to install, problem ended up being that I was using USB 3.0 ports, and there’s not much documentation on everything. Right now I have the os installed on a USB storage and I think that is causing a lot of performance issues, but I could also use some guidance on setting up a mineos and Windows 10 dual boot.

The other thing that I’m facing right now with the current installation via USB storage is that the FTB server won’t start, downloaded FTB direwolf20 profile, and the 1.7.10 vanilla minecraft profile, ran vanilla beautifully, but when I select the FTB profile and the FTB launchable jar, it says server start success on notifications but doesn’t actually start. Eula has been accepted and everything to. Even with importing a saved server that I had been running on Windows, it does the same thing.

I googled it and found that people were saying that I need to run the file but when I go into root shell and type “sh” it says “sh- 0: can’t open” am I doing something wrong?

FTB and modded servers are really @tNt’s strenght.

But I think your problems are less of a FTB vareity, and more of a filesystem/storage.

Your USB-storage, is it formated for FAT32 ? or in one of the linux filesystems? USB storage usually come, and like to stay in FAT32. FAT32 have some limits in filename and file structure that linux file systems do not have. This means that you might have problems starting or running certain servers that need and use files that break with this filename policy. I had that problem a while ago when I used CIFS / SAMBA to attach a remote windows share to my MineOS installation: Setting up and starting a pocketmine server

As for dual boot:
I take it for granted that you know you cannot run both OS’es on a dualboot system at the same time? You can only run one or the other. So If you want to run your minecraft server on MineOS partition, but play minecraft with your windows partition this will not work. If this is what you wish to do, you need to look into virtualization instead of dual boot. Take a look at (For example) Virtuallbox:
I ask this, since MineOS really needs a virtual or physical host for it to be available whenever you want it, instead of when you wish to boot your windows machine into your MineOS partition.

Yes the USB drive was formatted in fat 32 but the installer re-partitioned the whole 32gig drive as needed, and yes I know that I can’t run both os’s at once with a dual boot, but I want to be able to restart into Windows if I need the laptop for something else, so I want the option to boot from one or the other as I’m booting up.

As for virtualization, the reason I’m using mineos is because the laptop can’t really run Windows 10 and a FTB server effectively. So booting into something so minimalistic as mineos should provide a lot better performance.

So I should do what to get the FTB server to start?

I see.
Well, if the drive is partitioned properly , it should be fine there.

I’m not sure about using USB, but I can’t see any resaon as to why it should not work properly.

if i’m not mistaking doesn’t linux use like 2 or 3 partitions to operate? a storage partition, a swap, and a different one?
because as of right now i have everything on the USB drive as if it was my HDD. and i’m thinking my performance issues is that the system can access only one partition of the usb drive at once, thus storing information in RAM instead of writing it to the partitions.

because my performance issues are after the OS has been up a while and trying to do different things my free ram will continuously go down, then when it’s less than 1 g free that’s when the webui and almost everything starts freezing/lagging/running badly.

Although I could be completely wrong on all of this…

as for the dual boot, i had previously tried to do a MineOS and windows 10 dual boot on a different laptop and it was a GPT HDD with UEFI, and Grub pretty much “Broke” the EFI partition. So is there a way i can install MineOS to the actual HDD, and put the Grub on a USB drive so that i can just select the USB drive in the boot sequence, and it launch Grub then and be able to continue as normal. Also that way if the USB drive isn’t in, then the laptop would start windows 10 like nothing has ever even happened.

But i’m not sure how to get a Grub that is targeted to the HDD installed to a USB drive.

I put MineOS on the HDD instead of the USB drive and almost 2 hours later of it running i’ve not had a freeze/lag like i had previously.
Also i’ve been able to get the server to “start” per say, but almost an hour later and it’s still not booted up to where i can join, according to the FML-server log it’s still trying to run.

Actually, it finally started up, but mods that were disabled are now enabled, i removed the mods from the server folder via FileZilla, but when i select the FTB Profile, it adds those mods back in, and filezilla won’t let me remove those mods from the profile folders. help?

Apparently putting on the HDD effected everything because the server is running now and has been for about an hour or so now almost flawlessly, Definitely WAY better than a FTB server on windows 10 on this laptop.

wow, i have alot of questions about what you are trying to do. it would not have occurred to me to try this and i like it.

one is 'how do intend to access the MineOS WebUI if you ever did get a minecraft server up from a USB?


you seem really bright and i am just old. pushing 60. so while i am waiting for a file to u/l for a friend, i will nudge you in a direction. if not mistaken windows 10 comes with visualization so you could actually have MineOS ‘inside a shell’ in win10. i haven’t tried it yet biut intend to look into it at some point.

more found here:

and here:

how to get MineOS inside needs study.

FTB does that and i am looking at it as well. BTW the ‘profiles’ folder is CHMOD (owned) by ‘root’ and root access is required to remove anything there.

you should also find a 200mb or more file in 'server/(server name) folder and i think FTB replaces mods from there.

Good Luck!


yeah, running it completely off of the USB drive wasn’t working, performance wise and functionally either apparently. I will have to take a look into the shell inside of windows, that sounds very interesting, but at the same time since windows vista windows has become quite the resource hog just to be there, the laptop i’m putting the server on is a crappy dual core 4g ram 500gb 5400 RPM HDD HP pavilion, that’s why MineOS caught my eye so much because of it being a text based OS with an outside GUI, uses WAY less resources just to “Be” than windows does, and when limited on resources as this laptop is that’s a BIG thing.

What i would like to do now is have just GRUB on a USB that way i can put the usb in, select boot order and get into the MineOS, with windows being the main boot on the laptop, that way if company or family or anyone wants to use the laptop normally they would never know MineOS was even there, but it would still be very easy for me to boot into it.

Originally the whole purpose of installing MineOS completely on the USB drive was because the HDD “Was” portioned as GPT and UEFI, which after playing around with MineOS already and trying to dual boot with that, it just doesn’t work as Grub is a legacy boot that doesn’t play well with UEFI. But putting it completely on the USB drive “Bypassed” these complications.

Another Idea that could possibly work, but i’m not sure exactly how to install it with MineOS’s current install methods, but would be use the USB drive as the Logical Partition, and make the linux swap partition on the Host’s HDD, but would it be able to be moved to another host that was a linux swap partition also though…

MineOS was booted on the USB drive and you accessed the WebUI just like normal, the laptop was basically just using the USB drive as the HDD, so it still used the computers ip address and everything.

I got the server to work with the proper mods i was wanting and everything, used filezilla to import my whole server folder that i had been running from windows, used the WebUI to create server from import, then used the Vanilla 1.7.10 Profile, with the FTB runnable Jar. and everything worked properly. Being that my server is a modded version of Direwolf20-1.7.10, i was trying to use that profile, and that is what kept replacing my mod choices.

So what needed to be done on creating a new server is download both profiles, Vanilla 1.7.10, and DW20, run once with DW20 profile, then use FileZilla to edit the mods that you want to in the “server/(server name)” folder, and then run with the Vanilla Profile, but the FTB Jar.

A way to view the console is really needed though, because with all of my issues, once i got the right profile selected and all, fml needed a /FML Confirm command, and it took a while to figure out that’s what it needed because of not being able to see the console/FML- logs live.

All i see that MineOS is missing so far, is some good documentation and tutorials. For the little that i know about linux and shell, and commands, i was for the most part able to get all of that going fairly easily, just took the right environment for it to blossom. Thank you very much @hexparrot and everyone else in development of this! :smiley:

yes, i think you are just a bit underpowered there.

i have been trying to move in this direction but no time so just starting.

my sense is that forget FTB. just make a server and just add the mods they used to make theirs. and just use a vanilla client no need for the FTB client. it did not work out of the box with FTBPresentsSkyfactory25-2.5.2 recently and am still puzzled as to why. did not get back to that issue yet.

of note, the more mods, the more memory you will need. might you try to build the server you want with only the mods you want? the fewer the better?

on the bright side you have a perfect unit to use as a minecraft server once you get a new laptop :wink:

best regards,


This would take a LOT of work to do to get it working, It’s just WAY!!! easier to just use the FTB server.

The reason it didn’t work is because FTB actually “Cooks” the mods so that they work together. Being that they change and alter configs, block id’s, etc, etc.

Yes, and No.
Yes it’s going to use more memory, but not marginally more. For instance, FTB Ultimate, running off of 1.5.2 minecraft runs like 250+ mods, it actually doesn’t use more memory than the DW20-1.7.10 does and it only has 155 mods. That’s the beauty of how minecraft works in the first place, it only loads what is needed as it’s needed, the server i have going right now on MineOS is with 155 mods with an -Xmx of 1024, on that laptop mentioned earlier and for 2 people it’s been running almost flawlessly, at 1g it’s running WAY better than as if it was the same laptop and all on windows.

but yes fewer mods could be better, but which mods do you do with out, and majority of the time the mods that you could/would want to do without have VERY little impact on server performance if any.

from what i’ve learned from my experience so far, the best way to get this going and working would be to download a random profile, then with root access go in and copy your Skyfactory server profile into that new random profile, then also import it the normal way via a .zip and create server from profile. Then when launching the server choose that random profile and Skyfactory’s FTB “.jar” for the runnable jar and it should work. That’s essentially what i did by choosing the Vanilla profile that matched the FTB i was launching.

The Profile choice overrides whatever the /var/…/server/(Server-name) folder has in it. and by choosing the Vanilla profile, but using the FTB “.Jar” it over rode things that needed to be there and launched perfectly. I honestly don’t see or understand why a “Profile” like this is even needed. instead of a profile it should be a list of your servers just like the drop down box at the top of the WebUI, or possibly nothing at all, I Don’t know though, maybe one of the developers or writers would be able to chime in and clarify this one.

only this laptop is though, :slight_smile:

My desktop is AMD Phenom II x4 black edition water cooled 12gb Corsair Dominator Ram, AMD Radeon 6900 HD Graphics, with a Hitachi 2TB 7200 RPM HDD.

My “Other” laptop is an HP Envy, AMD Quad core, 12gb ram 1tb HDD.

the laptop for the server is my girlfriends, but she want’s to play also. So Far after FINALLY getting it up and running even on just 1gb of ram it’s been working flawlessly so far, even better than running the server and the FTB launcher on the desktop.

and btw. according to webmin sidebar i’m only using 1.74gb of 3.36gb in “real memory” (which i’m assuming is the real RAM) but the WebUI shows only 129mb free…?

i applaud your success, have fun!

and i will digest your post, mostly i was trying to do something for someone else as the normal way wasn’t working.

my setup handles things as they should, for the most part. my 2 girls love minecraft and have been asked to add the five nights at fredies mod to their custom server. they also enjoy FTBInfinity but rarely use all the mods.

glad to chat you,