Help - Manual restore

So things were going fine last night. This morning I saw the 1.9.1 update. I did both a Archive and Restore point before upgrading to 1.9.1. The upgrade somehow caused me to loose days of work. I attempted to use the restore point to before I upgraded to 1.9.1 and no joy. How can I use the Archive and restore to create a new server, like an import?

On the archive page, do you see the option to ‘create server from archive’?

It’s under the “actions” drop down menu, either use that or you can copy the archive from /var/games/minecraft/archives to /var/games/minecraft/import but it’d be easier for you to just use the drop down, being that there isn’t really a difference in which method you use (copying from archives to import you’ll have to use the “Import A Server” option on the side.

I have tried the create server from archive. When I log in to the new server made from the archive none of my stuff is there. That is assuming the block x,y,x in one game is the same at the other. I will try the import method, as I know that worked to import the game from my laptop to the server originally.


That gets me a new world as well :frowning:
Can someone tell me exactly what is the difference between the rdiff commands used for backup vs archive? I have some very small archives so I am curious

Difference between backups and archives

Few people make the distinction between Archives and Backups like MineOS does. There is a fundamental difference between these two, despite them often being used interchangeably.

The easiest way to understand the distinction between an archive and a backup is the format of an archive. File formats such as .tar are archive formats that simply combine multiple files into one consolidated file. Doing so has many benefits such as fewer file counts, less inode usage, less fragmentation and cluster waste. On the other hand, archived files are not usable in archive form (just like you have to extract a .zip file before you can access its contents).

Using the rdiff-backup algorithm creates a full miirrored backup of a directory. As a result, this results in at least a +100% use of space. However, because not all files change between backups, files that do not change do not have to be backed up again, which ultimately saves space over repeated backups. Incremental backups using rdiff-backup on files that have relatively low changes (in file count) will save a lot of space in the long run versus accumulating archives.

TLDR; it’s the difference between making a zip file and copying a directory.

Okay, so it seems to be only restoring me back to a few weeks ago, and that means I have lost a crap ton on work. Anyone know how I can apply all the incremental backups I have since then to restore me to present? What would the rdiff command look like?

Better yet, what is the rdiff command used to make the restore points, so I can try to figure out how to reverse it myself.

This is the command used to create restore points:

cd /var/games/minecraft/backup/awsum_srv
rdiff-backup /var/games/minecraft/servers/awsum_srv .

It does this as the server owner (the user you use to log into the webui). Attempting a restoration looks like this:

rdiff-backup --restore-as-of 2B --force /var/games/minecraft/backup/awsum_srv /var/games/minecraft/servers/awsum_srv

where 2B is replaced by however many backups ago you want to restore by. You can (when doing this manually in the CLI) use any of the rdiff-backup supported time formats.

Did you stop the server before or after making your archives and restore points?

I think after. I guess you are going to tell me that is the problem. I have never had a problem restoring a restore point that was saved with the server running before.

An archive or a backup can only save what is committed to disk at the time. save-all or stopping a server will invoke committing world changes from memory to disk.

the restore points where able to recover when I died, so I assumed that means the data was on the disk… I just figure out how to write some scripts to force save-all.

If you’ve updated your webui anytime in the last few months, you should have the option in the server status page of the webui per server.