Getting Nukkit server running


#1

So I looked into this last year and never followed through with it. This time around I thought I had all my ducks in a row. Webui is up to date, I’ve setup a nukkit server language has been selected, ports are open both in iptables and my router, log symlink is done and I get to the point in the reply below but dont see it in game even had it broadcast to lan etc. Maybe I missed something. Any help would be appreciated


#2

18-10-19 20:28:42 [INFO] Loading nukkit.yml…
2018-10-19 20:28:42 [INFO] Loading server properties…
2018-10-19 20:28:42 [INFO] Selected English (eng) as the base language
2018-10-19 20:28:42 [INFO] Starting Minecraft: PE server version v1.7.0
2018-10-19 20:28:42 [INFO] Selected Zlib Provider: 2 (cn.nukkit.utils.ZlibThreadLocal)
2018-10-19 20:28:42 [INFO] Opening server on 0.0.0.0:19132
2018-10-19 20:28:42 [INFO] This server is running Nukkit version git-4d5d030 “” (API 1.0.7)
2018-10-19 20:28:42 [INFO] Nukkit is distributed under the LGPL License
2018-10-19 20:28:43 [INFO] Loading recipes…
2018-10-19 20:28:43 [INFO] Loaded 954 recipes.
2018-10-19 20:28:43 [INFO] Successfully loaded 0 resource packs
2018-10-19 20:28:43 [INFO] Preparing level “Bedrock”
2018-10-19 20:28:43 [INFO] Epoll is available. EpollEventLoop will be used.
2018-10-19 20:28:43 [INFO] Preparing level “nether”
2018-10-19 20:28:43 [INFO] Default game type: Survival Mode
2018-10-19 20:28:43 [INFO] Done (1.402s)! For help, type “help” or “?”


#3

Starting Minecraft: PE server version v1.7.0

Ehm. I had a android PE version update onlyabout last week… The unofficial server versions tend to lag something awful. I addition I think they kinda lost their drive when Micrososft/mojang let their alpha version of their softwaer loose. So I think your problems is by an outdated server, and that *MineOS do not officialle supprt the official Mojang PE server


#4

#5

I didnt think to check which version I was running on my mobile. I was looking into the nukkitx site as well which has had commits as recent as a few days ago. The official mojang server starts extremely easy as I’ve already toyed with it but I need plugin support as well. Also I cant start the windows version on win7 only win10 which is an issue since my one server runs mineos turnkey and my other server is running win7 ultimate for ease of use with ARK survival evolved.


#6

The nukkit version on nukkitx website supports the newest MC version. I find if I run nukkit on my windows machine with a simple start.bat file it starts and everything including broadcasting on my local network(not external yet) but when I run it on mineos even with the version I downloaded from nukkitx site it claims its done/running but doesnt broadcast at all so I cant connect to it. Not sure if it’s something to do with linux as I dont currently have any systems running it atm or if it’s an issue of some sort with mineos. Currently it’s running on my win7 server alongside ARK