Getting Minecraft Pocket Edition Server Software Nukkit working with MineOS

Morning all

just joined the forum looking for a bit of information. I am currently building a new server running 2016 and i am planning to run MineOS in a virtual machine rather than have minecraft installed on the server as they currently are now.

So i know mineOS is for the pc edition of minecraft but my kids tend to use tablets and play on the minecraft pocket edition we use server software called Nukkit which is also Jave written.

So the questions is is there a way to run Nukkit inside MineOS along with the normal PC edition

and how can i go about transfering the existing worlds from my old servers into the new one running on MineOS ?

Any help or advice would be greatly received

Regards
Andrew

Pulling some info from Nukkit (GitHub | Homepage), it would appear that their server-software is jar-based, meaning that like every other Minecraft server-software, can be easily run within MineOS’ UI, so long as the jar is within the server’s root directory.


Some copy and pastes from the Nukkit GitHub Page:

Introduction

Nukkit is nuclear-powered server software for Minecraft: Pocket Edition. It has a few key advantages over other server software:

Written in Java, Nukkit is faster and more stable.

Running

Simply run start.sh or start.cmd, or execute java -jar Nukkit.jar.


Based on that, as previously stated you should be able to just drag in/upload the jar to the server root directory, located at “/var/games/minecraft/servers/{servername}” followed by selecting the jar via MineOS’ UI and running it, simple as that.

That, I’m not too sure about being that I don’t own or play any of the non-Java editions of Minecraft for numerous reasons, however I’d say it depends on how you had your old servers set up, what they ran on, etc but theoretically it should be as simple as dragging/uploading the world files/folder into the server root directory.


EDIT: Changed title from “MineOS pocket edition” to “Getting Minecraft Pocket Edition Server Software Nukkit working with MineOS”, changed category from “MineOS Turnkey” to “Server-Software”

EDIT2: You may also need to check the unconventional/not a conventional server checkboxes.

1 Like

Confirmed. All I needed to do was drop into the server’s directory and put in the appropriate jar file.

No profile necessary, and choose the XMX value according to the amount of memory you wish to allocate. The server started up, and you can read the console via the server.log tab.

I’ll look into adding this as an official profile.

Oh thank for that guys thats exellent news i will try transfer the world they were all created in jave versions but on a windows server rather than linux but i will figure out the file systems once i install mine OS. Although there is no AI mods there is a plugin that you can add which gives you the AI as well

but i will try and do a little how too as well while i set it up incase anyone else is looking at doing the same thing.

once again thanks

Regards
Andrew

I have created a new branch for nukkit: https://github.com/hexparrot/mineos-node/tree/nukkit

However, I have not merged it into the master branch because–while the download works and the server starts–it appears that the server dies without any error, whatsoever.

This happens both when invoked from the webui as well as me simply trying to run the server Jar from the command line manually.

Nukkit has been added to the profiles list and operates just like any other profile–very straightforward, but I’ll hold off on merging it in until I can get a good read on why the server itself dies without notice.

Morning

So i managed to transfer the pc version and import it no problem and it works perfect

so following what was said above i tried to setup nukkit and although the server runs i keep getting a sync pack with server error i have added the new port to the iptables and on the router i even tried setting up a new world rather than loading my previous one but still although the server runs i still can log into it with either windows 10 or kindle version i am at a lose as to how to get it working

nukkit has a log is named server.log and is hidden in the server direcotry root. (For me it did not show up automagically in the webui). what do it say?

If this log is not shown in the webui logviewer you can do the following using ssh:

go to your server directory:
cd /var/games/minecraft/servers/{servername}

make a “logs” directory (if it is missing):
mkdir logs

create a symlink to get the webui to see “server.log” as “latest.log” (which is one of the files it is looking for):
ln -s server.log logs/latest.log

When you open your webui now your logfile should show up. w

I suspect that your nukkit is stuck waiting for user input, at first run it stops to ask you what language you would like it to use. use the command input below the logs to answer with the code for your prefered language

2 Likes

I have looked over the log only thing I noticed is that is says it can’t bind to 0.0.0.0 : 19132 but nothing else is running on that port so I am unsure why that port would be blocked

can’t bind to 0.0.0.0 : 19132
That means there is something else running on port 19132. Do you have another pocket edition server running? A port number can be connected to one service (server) only. If you want several running on the same machine they must have separate port numbers, just add one to the port number if you all ready run a server: 19133

1 Like

I will try changing the port see if that works

Remember to use the correct port number when connection the Pocket Edition clients. If your server uses 19133, the client will have to specify that is shall connect to that port, if not it will connect to the server using 19132

That’s it got it working. Managed to get the saved games over as well excellent

Not to highjack the thread or anything but this is the only thing I’ve been able to find after nearly 3 days of searching. I’ve been running a mineos server for a few years now (started with crux now using turnkey) but with mobile gaming becoming more popular I’ve been looking into setting up a Nukkit server for my daughter and nephews. I haven’t had much luck though. I would like to install it alongside my current pc server so I don’t have to leave another computer running however I can’t seem to get it to start. I’ve tried following what I’ve read in this thread with no luck (putting the jar in a server folder etc) just as well i either am completely missing it or don’t have a server.log tab (maybe outdated webui? I resorted to manually setting up a profile for it as well, when I click start it says it started but nothing shows that it has. Anyways Muzzy182uk I was wondering if you could share your full experience with me or perhaps someone else can give me a hand at this. I’ve been racking my brain trying to get this setup.

Nukkit saves it’s logs in a file called server.log in the server root. Look a few posts above to see how to symlink that file to one that MineOS recognises and looks for.

Secondly:
Nukkit stops after first run waiting for user input to select prefered language. Do the symlink thing, then in the server log you may enter the requeted response.

thirdly:
I tried a few of the latest nukkit’s, and they are buggy or incomplete. The server started up nicely, but all inventory, and creative selector inventory, is empty, no blocks are spawned on destroy, and thus no blocks may be picked up.

I ended up going back to PMMP:https://jenkins.pmmp.io/. It’s really no harder to set up a php-based server than a java based, you just need to make sure the proper php-executables are available.

This means you have to DL both PMMP:https://jenkins.pmmp.io/job/PocketMine-MP/
And the latest PHP compilation: https://jenkins.pmmp.io/job/PHP-7.2-Linux-x86_64/

Extract the PHP library in the root of your server, so that you get a “php” directory.
Then copy the .phar file from PMMP to the dir, select in the WebUI dropdown, and start. You may have to accept EULA at some point.

Another dumb question when its referring to putting the nukkit jar file in the root of the server file is it referring to the existing server folder or should I make a separate folder for my nukkit server (this is the route ive tried already) no files are created alongside the jar file when rebooted

If I try to start the jar file from putty I get this as a response

Exception in thread “main” java.lang.UnsupportedClassVersionError: cn/nukkit/Nuk kit : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14 2)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)

I figured out my above error, since my server has been running flawlessly for roughly 2 years ive lacked updating most things so my java was still java 1.7_79 updated it and now if loads and I can see it in the webui. Now when I try to start my server from the webui it says server is not assigned a valid profile

What version/commit of MineOS are you using?

If you’re using MineOS node, just update the webui to the most recent commit and nukkit is an official profile that should be only a couple of clicks.

Python then? Well, you definitely don’t need to upgrade (because thats a lot of work and a lot of steps), though it’s only in nodejs that nukkit is so point and click. As far as creating a profile for nukkit, though, you should be able to copy effectively the mojang vanilla profile, since it’s just a simple jar. If you drop the jarfile in the right directory in profiles, fields like URL won’t matter, etc.

As Imelsom said, it’s likely that this game is halting waiting for user input on which language to use. This means it’s also just as possible to invoke this jar manually from the CLI and after that one-time-setup, close the server, and use the webui exclusively from then on.

Many thanks for the info, I’ve gotten beyond the issue with the language selection via putty by starting the jar manually and selecting it. I had a feeling you might say my webui is out of date however upon searching I’ve either missed how to update it or just haven’t understood what I was reading.

Hey I managed to get nukkit running from the webui but to setup the jar I have to us putty to run the wizard after that I just selected the nukkit jar in the webui and started it.

But since the 1.1.5 update they have not updated the jar yet so I am now installing pocketmine and so far everything seems to have been working fine on mineos

Ive got the language setup taking care of through putty but to be honest I’m not even really sure what version I downloaded of nukkit. All I know is on my windows pc it ran without any issues which is why I decided to follow after it instead of pocketmine. Currently my webui is ce19bf4. Ive tried different senarios found in the forums to update since im not sure how up to date it is. They are usually returned with and error or this file doesn’t exist such as the one called webui_update.sh (cant remember exact name but i know this is close)