FTBrevaltion with one extra mod


#1

Im really lost with this whole trunkey/mineos thing. I ve only used windows my whole life and really want to try something new. I wanna start a server for me and a couple of friends of mine but having trouble. I installed mineos and can get to an ssh panel and log in as root but thats about it. I tried using to web interface to download my server files but it wont work since i added one mod to the pack. Im stuck at this point and googling hasnt helped me. Also i dont know how to setup a diffrent profile besides root.


#2
  1. you shouldn’t be logging into the webui as root. You can, however, log in with literally any other user that you can log into a terminal session with.

In MineOS turnkey, you were guided to set the password for the mc user as well as the root user; use the mc login instead.

It’s possible the mod you installed was done incorrectly and it has made the server stop working (no longer starting).

Usually the behavior you describe is when people add files to the server as root, but actually run the server as someone who isn’t root.

It’s not hard to trace which of these is pertinent here, but since you’re doing everything as root, I’m going to say this: start your minecraft server over fresh with these new guidance steps and abandon your existing world/webui entry.


  1. log into the webui as root and delete all existing servers within. Start fresh.
  2. log out of the webui and then back in as mc (or any other non-root user).
  3. create a server with this user
  4. start the server
  5. confirm it works and can be logged into
  6. log into SSH but as mc (or whatever user you used in step 2)
  7. add the mod you want.
  8. start the server and confirm it works.

Golden rule: if you’re working with the webui to manage your webui installation/update it, use root. In all other cases, if you’re working with the webui/ssh to create and manage actual minecraft instances, never use root.


#3

I now know to use mc for everything Minecraft related and deleted my server off of root, but I’m still struggling even to get a vanilla server started. I wanna try and start a vanilla server before moving on to an advanced modded server. When setting up the vanilla server, I left everything blank besides the game mode and difficulty. I changed the profile to 1.13.2 and the runnable jar to minecraft_server1.13.2.jar and accepted the EULA, and it still won’t start. I am struggling, and any help would be awesome @hexparrot


#4

If possible, provide any of the latest logs in /var/log/mineos.log.

Beyond that, SSH to the server and log in with your mc credentials.

  1. cd /var/games/minecraft/servers/
  2. ls (lists your available servers)
  3. cd [servername]
  4. ls (lists all files in that server’s directory)
  5. java -jar minecraft_server.1.13.1.jar nogui (adjust filename as appropriate to your own results)

This should manually invoke the Minecraft Vanilla server–whatever reason you can’t get the server up should be displayed directly to your terminal session here. Remember, this is done as mc!


#5

{“command”:“create”,“server_name”:“test_server”,“properties”:{“generate-structures”:true},“level”:“info”,“message”:"[WEBUI] Received emit command from 192.168.1.19:mc",“timestamp”:“2018-10-22T18:29:13.238Z”}
{“level”:“info”,“message”:"[test_server] Discovered server",“timestamp”:“2018-10-22T18:29:13.249Z”}
{“level”:“error”,“message”:"[test_server] Create tail on logs/latest.log failed",“timestamp”:“2018-10-22T18:29:13.249Z”}
{“level”:“info”,“message”:"[test_server] Watching for file generation: logs/latest.log",“timestamp”:“2018-10-22T18:29:13.249Z”}
{“level”:“error”,“message”:"[test_server] Create tail on server.log failed",“timestamp”:“2018-10-22T18:29:13.249Z”}
{“level”:“info”,“message”:"[test_server] Watching for file generation: server.log",“timestamp”:“2018-10-22T18:29:13.249Z”}
{“level”:“error”,“message”:"[test_server] Create tail on proxy.log.0 failed",“timestamp”:“2018-10-22T18:29:13.249Z”}
{“level”:“info”,“message”:"[test_server] Watching for file generation: proxy.log.0",“timestamp”:“2018-10-22T18:29:13.249Z”}
{“level”:“error”,“message”:"[test_server] Create tail on logs/fml-server-latest.log failed",“timestamp”:“2018-10-22T18:29:13.250Z”}
{“level”:“info”,“message”:"[test_server] Watching for file generation: logs/fml-server-latest.log",“timestamp”:“2018-10-22T18:29:13.250Z”}
{“level”:“info”,“message”:"[test_server] Using skipDirEntryPatterns: world,world_the_end,world_nether,dynmap,plugins,web,logs,region,playerdata,stats,data",“timestamp”:“2018-10-22T18:29:13.250Z”}
{“level”:“info”,“message”:"[test_server] mc (192.168.1.19) joined server namespace",“timestamp”:“2018-10-22T18:29:13.289Z”}
{“level”:“info”,“message”:"[test_server] Server created in filesystem.",“timestamp”:“2018-10-22T18:29:13.302Z”}
{“level”:“info”,“message”:"[test_server] 192.168.1.19 issued command : “modify_sc”",“timestamp”:“2018-10-22T18:29:22.538Z”}
{“level”:“info”,“message”:"[test_server] received request “modify_sc”",“timestamp”:“2018-10-22T18:29:22.539Z”}
{“level”:“info”,“message”:"[test_server] 192.168.1.19 issued command : “modify_sc”",“timestamp”:“2018-10-22T18:29:24.977Z”}
{“level”:“info”,“message”:"[test_server] received request “modify_sc”",“timestamp”:“2018-10-22T18:29:24.977Z”}
{“level”:“info”,“message”:"[test_server] 192.168.1.19 issued command : “modify_sc”",“timestamp”:“2018-10-22T18:29:25.856Z”}
{“level”:“info”,“message”:"[test_server] received request “modify_sc”",“timestamp”:“2018-10-22T18:29:25.856Z”}
{“level”:“info”,“message”:"[test_server] 192.168.1.19 issued command : “modify_sc”",“timestamp”:“2018-10-22T18:29:26.710Z”}
{“level”:“info”,“message”:"[test_server] received request “modify_sc”",“timestamp”:“2018-10-22T18:29:26.710Z”}
{“level”:“info”,“message”:"[test_server] 192.168.1.19 issued command : “modify_sc”",“timestamp”:“2018-10-22T18:29:27.386Z”}
{“level”:“info”,“message”:"[test_server] received request “modify_sc”",“timestamp”:“2018-10-22T18:29:27.386Z”}
{“level”:“info”,“message”:"[test_server] 192.168.1.19 issued command : “accept_eula”",“timestamp”:“2018-10-22T18:29:30.837Z”}
{“level”:“info”,“message”:"[test_server] received request “accept_eula”",“timestamp”:“2018-10-22T18:29:30.838Z”}
{“level”:“info”,“message”:"[test_server] eula.txt detected: ACCEPTED (eula=true)",“timestamp”:“2018-10-22T18:29:31.298Z”}
{“level”:“info”,“message”:"[test_server] 192.168.1.19 issued command : “start”",“timestamp”:“2018-10-22T18:29:32.153Z”}
{“level”:“info”,“message”:"[test_server] received request “start”",“timestamp”:“2018-10-22T18:29:32.154Z”}
{“level”:“info”,“message”:"[test_server] 192.168.1.19 issued command : “modify_sc”",“timestamp”:“2018-10-22T18:29:52.750Z”}
{“level”:“info”,“message”:"[test_server] received request “modify_sc”",“timestamp”:“2018-10-22T18:29:52.751Z”}
{“level”:“info”,“message”:"[test_server] 192.168.1.19 issued command : “start”",“timestamp”:“2018-10-22T18:29:53.131Z”}
{“level”:“info”,“message”:"[test_server] received request “start”",“timestamp”:“2018-10-22T18:29:53.132Z”}

This is my latest server log for my test_server


#6

putty%20pic

@hexparrot


#7

It didn’t go farther enough in the logs to tell me what version of the webui you’re using. If this is a fresh install of MineOS Turnkey, you’ll want to update the webui.

Follow the steps here to update the webui.

In all likelihood, it just means that the webui version you’re using is still pointing to an old/outdated URL for Minecraft 1.13.2, before Mojang changed the URL format.


#8

I updated the Webui using the steps you gave me but the server wont start. Im wondering if it has something to do with me having to setup a static ip for it and maybe forwarding a port. @hexparrot


#9

The error from your screenshot shows that the downloaded jarfile is corrupt, so you want to re-download it.

You just needed to update the webui because I guess old versions of the webui had now-outdated URLs in it.


#10

alright i finally got it to go up and it is. I’m just confused on how to allow my friends to join and how to pick an ip. Also do you recommend setting up a static ip for my local network? btw thank you you are really awesome @hexparrot


#11

So i finally got a vanilla server started and my friend joined perfectly. So now I wanna make a one with just basic FTB revaltion without my added mod. I did everything the same and now it wont start for that. @hexparrot I also tried to start it manually and got thisnew%20new%20pic


#12

So somehow i figured it all out. I know have a ftb revelation 2.5.0 server with biomes o plenty and lost souls. I had to manually change all the permissions on the ftb profile to be avaible to all and then manually run the FTHInstall.sh