FTB DireWolf20 1.6.4 8GB Hard Drive Almost Full After 1 Week

I am running FTB Direwolf20 1.6.4 on MineOS Turnkey in Virtual Box.

Because of my lack of familiarity with servers in general and Minecraft specifically I did some research and thought an 8GB hard drive would be big enough. After about a week in operation with around 5 total players, definitely less than 10, the hdd comes up as 95% full when the server is stopped and jumps to 100% full when it is running and there is someone logged on and then crashes.

I have no issues in creating a new VB guest with a bigger hdd but I would like to know if this is normal for Minecraft or DW20 specifically or is there something wrong that I haven’t been able to find. I’d also appreciate some suggestions as to what size hdd I should use for DW20 for 10 players.


How frequently are you making backups and archives?

The webui lists how much space each are taking–and you can address running low on space by either:

  • removing old/unwanted backups and archives
  • reducing the frequency of backups and archives
  • using larger partitions/hdd

I had forgotten about the backups and archives. I got rid of all but one of each and while the disk usage went down, I’m still having issues. I deleted the profile and the server. Created a new profile and updated it successfully. Now when I try to create a new server I get a create [error] message in a red box. The server doesn’t show up on the dashboard but when I try to make a new server with the same name I get Ignoring {create}: server already exists even after I remove it from /var/games/minecraft/servers. I even tried re-installing MineOS with no success. I’m not sure where to go from here.


MineOS is meant to manage all the aspects of Minecraft on the file-system side so in most cases, that means you won’t ever need to delete files manually via the command line.

For example, on the server overview page, there is a set of three checkboxes which indicate all of the locations that must be deleted for MineOS to accept a server is gone and deleted (removing just one isn’t enough).

If you have already manually deleted /var/games/minecraft/servers/servername, also delete the corresponding folder in archives and backups.

When you say you tried re-installing MineOS, are you saying you did a full re-format? Because if so, there’s no way that the existing server should have persisted from one to the next…

Also, a server name is just a server name–there’s not much to it. If you find that you can’t create a server (even though we know now the reason you couldn’t), you could also simply try creating it with a different name–if it worked, you’d be able to deduce there’s something specific to the name that was botched (rather than follow up with a full reinstall, which takes much more time).

The problem is that the server is not showing up on the dashboard in order for me to select it and delete the appropriate files using MineOS so I had to go in manually. Here’s the procedure I’m following, which worked before I started having hdd issues:

  • Create profile (I did custom FTB and vanilla stock profiles, results were the same for both)
  • Profile created box pops up.
  • Update profile. X becomes check mark, md5 pops up.
  • Create new server
    Name - Letters, underscores, periods. No special characters or spaces
    Group - mc
    Basic settings for everything else, no java tweaks.
  • Submit
  • Create [error] message in red box pops up.

ls /var/games/minecraft/servers/servername shows the server, but it is an empty directory. I tried changing the group ownership for /var/games/minecraft/servers from root to mc, but that didn’t do anything. Chmod g+w for it as well and that did nothing. Does the Create [error] message result get logged anywhere? Also what are the permissions for /var/games/minecraft/* . Mine were all root root after fresh install.



Each of the child directories to /var/games/minecraft should be owned by root. Each of the server-named directories should be owned by the user, such as mc.

/var/games/minecraft (root)
/var/games/minecraft/servers (root)
/var/games/minecraft/servers/servername  (mc)

Again, for whatever reason you’re getting that red box is likely because you have some directory by that name. I can’t immediately explain why there’s no files in that directory, because that’s precisely what “create” does: it creates three directories, server.properties, and server.config.

Feel free to delete those server names and try again–or more importantly, try creating a server with a different name. If it works, we know the process works and somewhere along the way that one server name, its files and permissions got botched.

Take some screenshots may also help.

I think there is an issue with the process because when attempting to create a vanilla server using the provided stock profile and three different server names always comes up with a create error and an empty directory at /var/games/minecraft/servername/. I think I’ll just scrap the whole thing, including the VB instance and start over and see how that goes.