FreeNAS mineos Server won't start


#1

I just made a FreeNAS MineOS server with the plugin. Able to go through the WebUI no problem and create a server. The issue comes when I try to start it. When I press start the server, nothing happens… I’ve accepted the EULA, when I hit accept nothing really happens… the button gets pressed and no check mark or anything appears (I’ve verified that eula=true in the file). I’ve tried killing it, restarting it, shutting down but of course those don’t work because it’s not up in the first place…

mineos.log:
{“level”:“info”,“message”:"[Order_of_Bros] received request “start”",“timestamp”:“2017-06-16T16:37:16.104Z”}
{“level”:“info”,“message”:"[Order_of_Bros] 192.168.0.27 issued command : “start”",“timestamp”:“2017-06-16T16:37:18.199Z”}
{“level”:“info”,“message”:"[Order_of_Bros] received request “start”",“timestamp”:“2017-06-16T16:37:18.200Z”}
{“level”:“info”,“message”:"[Order_of_Bros] 192.168.0.27 issued command : “accept_eula”",“timestamp”:“2017-06-16T16:37:22.232Z”}
{“level”:“info”,“message”:"[Order_of_Bros] received request “accept_eula”",“timestamp”:“2017-06-16T16:37:22.232Z”}
{“level”:“info”,“message”:"[Order_of_Bros] 192.168.0.27 issued command : “accept_eula”",“timestamp”:“2017-06-16T16:37:22.416Z”}
{“level”:“info”,“message”:"[Order_of_Bros] received request “accept_eula”",“timestamp”:“2017-06-16T16:37:22.416Z”}
{“level”:“info”,“message”:"[Order_of_Bros] 192.168.0.27 issued command : “accept_eula”",“timestamp”:“2017-06-16T16:37:22.609Z”}
{“level”:“info”,“message”:"[Order_of_Bros] received request “accept_eula”",“timestamp”:“2017-06-16T16:37:22.609Z”}
{“level”:“info”,“message”:"[Order_of_Bros] 192.168.0.27 issued command : “accept_eula”",“timestamp”:“2017-06-16T16:37:22.815Z”}
{“level”:“info”,“message”:"[Order_of_Bros] received request “accept_eula”",“timestamp”:“2017-06-16T16:37:22.815Z”}
{“level”:“info”,“message”:"[WEBUI] mcserver connected from 192.168.0.27",“timestamp”:“2017-06-16T16:37:26.309Z”}
{“level”:“info”,“message”:"[Order_of_Bros] mcserver (192.168.0.27) joined server namespace",“timestamp”:“2017-06-16T16:37:26.747Z”}
{“level”:“info”,“message”:"[Order_of_Bros] 192.168.0.27 issued command : “accept_eula”",“timestamp”:“2017-06-16T16:37:33.272Z”}
{“level”:“info”,“message”:"[Order_of_Bros] received request “accept_eula”",“timestamp”:“2017-06-16T16:37:33.273Z”}
{“level”:“info”,“message”:"[Order_of_Bros] 192.168.0.27 issued command : “start”",“timestamp”:“2017-06-16T16:37:33.617Z”}
{“level”:“info”,“message”:"[Order_of_Bros] received request “start”",“timestamp”:“2017-06-16T16:37:33.617Z”}


#2

First question, what version Minecraft server,–are you using the official 1.12 or a different one?


#3

attempting to use the official 1.12


#4

Official 1.12 requires Java8–can you confirm you have Java8 installed on your FreeNAS system?


#5

ahhhhhhhh, So I went through and installed Java via pkg install openjdk screen and I’m still running into the same issue after a restart. When I press start, the button get’s clicked but literally nothing happens.


#6

Yes, but confirm that actually is java8.

java --version


#7
root@mineos_1:/ # java -version                                                 
openjdk version "1.8.0_131"                                                     
OpenJDK Runtime Environment (build 1.8.0_131-b11)                               
OpenJDK 64-Bit Server VM (build 25.131-b11, mixed mode)

Upgrading to 1.12 / Java 1.8 / FreeNAS 9.10.2
#8

Can you confirm you can start any other server, one that isn’t 1.12?

Also, strictly speaking, we need to know that the Java that get’s run for mcserver is 1.8, so far we just know that root has Java 1.8.


#9

Just tried with a 1.8 server and it seems to have worked just fine… As soon as I try to switch it to 1.12 it will no longer start. I don’t know how another version of Java would have gotten on there as it’s a fresh install and I’ve never installed any other version that I’m aware of.


#10

You can try logging in as mcserver the user, and then trying to invoke Java with the 1.12 jar manually. It will be the most direct way to see any error messages.


Upgrading to 1.12 / Java 1.8 / FreeNAS 9.10.2
#11

I’m not sure how to log into the Jail shell with mcserver from within the FreeNAS WebUI.

edit: I was able to look in the jail files. I searched for java in the jail, and this came up…

\jails\mineos_1\usr\local\openjdk7\jre\lib

So I’m assuming that would be java 1.7, and if so how would I update this?