FreeNAS MineOS Import Issue

About a week ago I migrated my NAS to FreeNAS from windows10. One of the other functions that the system was doing was hosting Minecraft servers. So after installing FreeNAS I installed MineOS and proceded to import my existing servers. They were all Spigot servers, importing was easy enough. Just zipped the world folder and placed it in /var/games/minecraft/import . No problems so far.

Because the server is located in my bedroom after running FreeNAS/MineOS for about a week I started to be bothered by the fact that because MineOS was installed on my main storage pool (5 1tb HDDs in z2) the drives were being read and written to in the middle of the night. I didn’t have this issue before when the system was running windows because the servers were on the C drive which was an SSD.

Yesterday I installed an extra 500gb SSD I had laying around into the system so that I could run MineOS on that instead. I created archives of all of my servers and copied the TGZ files to my local machine. Next, I deleted MineOS from FreeNAS, changed the “Activated Pool for Jail Manager” to the SSD, and restarted FreeNAS for good measure.

Once the system booted backup I proceeded to reinstall MineOS. I logged into the WebUI, installed BuildTools.jar as well as the 1.14.4 version of spigot.

Here is where my problems start. I copy the archive of one of the servers from before into /var/games/minecraft/import . In the WebUI, I click on “Create server from Archive” and enter a name for the server. As soon as I click “Create server from Archive” I am taken back to the dashboard screen but now Server Settings and Backups and Restores are in the left sidebar. When I go into Server.Properties it is totally blank and it just gives me the option to add a new entry at the top. Another thing of note is that “Currently Selected Server” is blank.

At this point, I go into Server Status and click Start. I select Buildtools-latest as the profile but under “Change runnable jar to:” there are no options even though the most recent release of spigot is installed. From here I cannot proceed any further. Also if I refresh the WebUI at any point Server Settings and Backups and Restores disappear from the left sidebar.

These are the troubleshooting steps I have tried so far.
-Restart MineOS
-Restart whole server
-Try different archive of a different server.
-Extract TGZ file and then zip the contents and try importing the server as a ZIP instead (same result)
-Delete and reinstall MineOS

The last thing I thought of doing was just trying to create a new server and then once I had the new server setup I could paste the files I extracted from the archive into the new servers folder. But I can’t even create a new blank server. I get the same issue where I have no options under “Change runnable jar to:” even though the 1.14.4 version of Spigot is installed.

There is one more thing after all of that. After I try to import from one of my archives or even just create a new server if I close the WebUI and then try to navigate back to it I just get an error message in chrome that says “This site can’t be reached” " refused to connect. “ERR_CONNECTION REFUSED”. The way to get back into the WebUI is to go into FreeNAS and restart MineOS. Then I can get back into the WebUI but has none of the servers that I previously tried to import or create new are there.

My conclusion is that there is something broken with my install of MineOS but I do not know how to fix it since I have already tried deleting and reinstalling MineOS multiple times. Is there some issue with MineOS and running on USB SSDs that I am not aware of? If you have any idea on what is going on please let me know.


I don’t maintain the FreeNAS plugin, so my first question is a) is the webui updated and b) can you provide the /var/log/mineos.log so we can look for errors.

  1. In FreeNAS it says the version of Mine OS is “11.2-RELEASE-p14”
  2. Here is the log

Once again, any help is greatly appreciated.

["TypeError: path must be a string or Buffer","    at Object.fs.readdirSync (fs.js:904:18)"," 
   at Object.mineos.server_pids_up (/usr/local/games/minecraft/mineos.js:59:17)","    at (/usr/local/games/minecraft/mineos.js:1265:27)","  

This error suggests to me that the Linux-compatible /proc filesystem isn’t mounted therefore MineOS can’t iterate the list of process IDs that is required to tell whether or not servers are up or down.

I have a potential explanation, but not a solution because I haven’t really used the FreeNAS appliance. I’ll check the plugin creators FreeNAS thread to see if this is a recognized issue.

Could it be something to do with the fact that the drive I have MineOS on is connected via USB instead of SATA?