Forge 1.16.x and MineOS

I am having difficulty installing the latest forge versions, and while I know that they are in open beta, I don’t know if the problems stem from Forge or MineOS (or, I suppose, user error).

I’ve got MineOS installed as the distro on an old box of mine, and had it working fine for Blightfall and also for a 1.16.1 vanilla server.

When I try to run the Forge server jars from the Profiles page, (which are up to date!) however, they only run for a few seconds, and generate error logs. I’ve been wrestling with it for about 6 hours over the past several days. I’ve tried installing all sorts of packages that errors were suggesting I was missing, such as java-atk-wrapper.

I eventually ended up disabling the accessibility feature and now it is throwing errors asking about X11 display?

JVM info: Oracle Corporation - 1.8.0_252 - 25.252-b09
Found java version 1.8.0_252
Exception in thread “main”
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
at java.awt.GraphicsEnvironment.checkHeadless(
at java.awt.Window.(
at java.awt.Frame.(
at net.minecraftforge.installer.SimpleInstaller.launchGui(
at net.minecraftforge.installer.SimpleInstaller.main(

I can of course make changes to box from its own keyboard and monitor, but am attempting my installations using the webui from a local pc.

If I have asked this in the wrong place, I apologize.

Thanks for taking the time to read!

What are the values you entered into the Xms and Xms fields?

Ya know, I had to tinker with that a bit on the other servers I was running on the machines, and ended up settling for 256mb for the min and 2048 for the max? Seems to do ok. I don’ remember if I specifically did that with this, but I will go double check.

I’ve found that not setting the min value doesn’t impede the performance. Also check to make sure you have -nogui in your arguments. That might be the reason why it’s looking for the X11 interface.

Thanks for the tip! I uh… went to check and had the values I thought. But when I ran it again it… worked? Suddenly. Uh.

I don’t know.

I’m going to try to figure out installing mods and such now I guess! Thanks for the help.

1 Like