[FIXED]Cant start skyfactory4 server

I wanted to create a skyfactory server for me and my friends. The server works on my main pc, starts up fine and i can join it no problems. I then take the folder containing the server and move it to my mineos server folder via filezilla. i go to start it up using “forge-1.12.2-14.23.5.2854.jar” as my jar file and it doesnt start up. i then tried using “minecraft_server.1.12.2.jar” as my jar file and it starts up fine but its just a vanilla server. im not sure what i need to do to get this to work,

I think you should first create a forge server an then try replacing the world folder for the SkyFactory folder. Make sure the server.preferences file has the matching world name.

This is just my guess, as I don’t use forge, but it’s the same concept as what I posted to transfer stand-alone worlds to a server.

thats the problem. it wont start a forge server. any version of forge i use just wont start

I FOUND THE FIX.
i had to install openjdk8 and set that as my devault java. i have my server up and running now