First-time runnning help

– Just one last thing –

Where would I edit the FULL server.proerties file?
Is the only way to do that via SSH/SFTP?

Also, I tried starting a server as the “MC” user - it just did nothing apart from going “UP” for a few minutes an drying - no logs were created, or for atleast as I can see.

After attempting to start, it says this in the notifications area.



Sorry @iMelsom for calling you into this again, but it seems not all my issues are actually resolved… :stuck_out_tongue:

the only place to edit the file is in its location in the server directory, accessed with ssh.

/var/games/minecraft/servers/name of your server/

the meny choice in the WebUI shows the entire contents of the file, but as separeate variables and values. There are several more variables and properties that can be set, but if they are not shown in the WebUI, they are not set in the file. Here is a list of all possible variables/value pairs:

Now, to diagnose why your server stops we need at least two logs (depending on what type of server you are trying to run):

/var/games/minecraft/servers/name of your server/logs/latest.log

We also need to know (or at least it gives us an idea of where to start looking for errors) what type of server you are trying to start (vanilla? Bukkit/Spigot? An FTB-type server? A PockeMine (pocket edition) type server?). Al of them have different pitfals and ways to crash. Vanilla (the ordinary not modded Mojang Minecraft server) is the easiest one to run, and hardly ever crashes.

one question to start with is: Did you create your server as root? Then you need to log in with root and remove it (easiest way if it is a fresh server), then log out, then in again and create it with the MC user. creating it with root sets user rights for all files and directories for your server to root only. This means the MineOS user, and the MC user, cannot access those files, and the server crashes. (simplified explanation). If it is an older world you have built quite a lot in, you need to manually go to the directory through ssh, ad change user and group ownership of all files and directories (including the directory named after your server itself) to that of the mc user.

I sorted my issues with the file - there is a “+” icon for the nodes I need to add.
I am trying to run BuildTools.jar
I am using the MC user.

How would I go around sending you the log files?

Ah. you are trying to run a spigot / bukkit type server.

buildtools.jar is not a server file. it is a file used to build a server file for that type of server. Trying to run that as a server file will crash.

spigot / bukkit is not released properly for minecraft 1.11, so the build process fails to produce a server file. I just tried because I have a couple of bukkit servers that need to be upgraded to 1.11…

to use spigot / bukkit you need to go to the apropriate menu (spigot / Craftbukkit),

  • press “Download latest buildtools.jar”
  • use the “Build Spigot” button beside the 1.10.2 version.
  • when the build is done (look at the output window at the bottom of the page) press the “Copy to server” button that shows up when done.
1 Like

That makes so much sense! I feel silly now! :frowning:
Okay, It’s only showing in the “Spigot / Craftbukkit” tab server files up to 1.9.4 - where are the 1.10.2 files you spoke about?

Would 1.11 files be avalible soon?

Thanks @iMelsom for helping! <3

How old is you MineOS installation?

In the top corner (hvere the user name is) there is a small downwards pointing arrow. Press that one and check your commit, and then try pressing “Refresh profile list”.

You may need to upgrade your MineOS to a newer commit, but refreshing profile list should get all the current server versions.

Take a look at the following thread: Megathread for MineOS webui issues

And here is how to update the WebUI:
(and to update the WebUI you need to use root ;D)

Right, it says “git commit: 0e45be7”

I used the x86 installtion from the homepage.
If 0e45be7 is not the latest build I shall update it.
And I’ll need to use root. :wink:

1 Like

That being said, I am starting to suspect that the latest buildtools.jar is buggy. I cant seem to build any version right now.

So it’s not mine, your, or MineOS’ end - it’s BuildTools?

Okay… Seems ood…

Latest commit is d9a604b

Maybe. It may just be bad luck (and a bad commit from MineOS do not in itself host or make thos files. It simply makes them available from those who make them. So if they release a buggy or faulty version, MineOS will still DL it, but will not be able to make it work…

Right I see - so I still need to update my WebUI - BUT, also need to wait for the Spigot team to fix their Build Tools?
Is it worth updating or should I wait?

It’s allways worth it to upgrade the WebUI.

But for running bukkit/spigot: Just start with a vanilla server, and play that one untill a successfull build is possible.

Will do then.
Updating seems easy enough.

Hope to see Spigot to fix the BuildTools…

According to this forum post :
they have released a version for 1.11, but not for default build, which may be why MineOS faults on trying to build that version. MineOS tries to build the latest version without version info, since it assumes that is the default version. Buildtools is not configured yet to build 1.11 by dfeault.

But looking at their Jenkins page the latest Buildtools i over a month old:, wich do not soud right according to a recent build release…

And if it faults on a default build, it should not fail on a earlier version build where the version is specified…

There is weirdness here…

Indeed it does - huh…
Just updating my WebUI - seems alright.

There seems to be some chagne in the buildtools, or a minor bug that comes around when a newer version is available but not default while trying to use buildtools.

You can do it manually though:

to do so you need to have buildtools.jar in your server directory.
It may be copied from its profile location: /var/games/minecraft/profiles/BuildTools-latest/
I think you may need the latest minecraft server jar as well
location (if downloaded through profiles): /var/games/minecraft/profiles/1.11/

Through SSH (mc user is enough) enter your server directory:
cd /var/games/minecraft/servers/your server name/

run the following command:
java -jar BuildTools.jar --rev 1.11

Then Wait untill it is done. It takes a while

When done, open WebUI, and the file "craftbukkit-1.11.jar should appear in your runnable jar dropdown menu in your server status.

Okie dokie - I just ran this from the update page:

cd /usr/games/minecraft

git fetch
git merge origin/master
npm install


I ran that because:


Did not work. I am now on WebUI version d9a604b - LATEST! Woohie!

Would of attempting, like a silly person, running BuildTools.jar of damaged MineOS? Will I need to re-install? Would it of used diskspace? I’m more than happy to re-install…

1 Like’s site for learing to navigate and use the shell (SSH / Terminal):

I got FileZilla and PuTTY installed on my access machine - it’s working! Huzzar!

1 Like

Nope. Only thing that happends is that Buildtools fails to run, since it lacks information to finish.