Failing to connect to Web-UI, networking issue likely

I am currently setting up a Mine-OS server in my apartment using an old desktop. The OS is running standalone on the desktop, which I installed through Turnkey. I have gone through the guided installation, setting up everything that I was prompted to set up, only I can’t connect to the server through the IP it provides. I have made sure I was typing it in full, including the https and port number, but I get a ‘could not connect’ error anytime I try to open the link. I’ve used three different browsers and made sure ‘node’ was running, but I still cannot connect.

I am afraid this may be an issue with my internet itself, which I unfortunately cannot change because it’s through my apartment building. If this is the issue, is there any way around it? And if it isn’t, what might I be doing wrong?

Are you able to connect to the server via ssh (with a client such as putty?)

The IP it provides is either a) an IP you entered or b) an automatically-assigned IP address from your router.

What is that IP address, and see if you can connect via ssh. If you cannot, the installation (or more specifically, the network configuration) was done improperly.

The MinesOS IP is, but the SSH it gives me is mc@ port 22. I know only the second matters but I tried both, neither worked. I’ll reinstall and see if that helps.

It’s pretty irregular for home-hosted servers to be issued 10.x.x.x IP addresses. Is this something you chose? Are other devices on your network also 10.x.x.x?

The most frequent reason we see 10 addresses is when people are using VMs, e.g., virtualbox, but since you said you’re doing bare metal, the first place to check is if this is the same network as your other devices.

A reinstall can only do so much, but when it comes to entering in the network info (or getting it via DHCP), you should expect the same result until that address is fixed.

IP addresses that start with 10.x.x.x is generally used in enterprises and other businesses. This set up may be provided to all residence and the Housing Authority might have the ports blocked/restricted. One option is to see if the management is able, or willing, to open the required ports. Another option is to set up a proxy service/server to pass through a vetted port to your server. Finally, the only option else really isn’t a workaround, but just connect locally, on private connection, no internet.